Wildcard SSL and CloudWays

Hey, I’m new here and I’m not that technical so please don’t ask me to do much technical work without talking to me like I’m a simpleton.

I have CloudWays hosting. On there I ran into issues trying to set up a wildcard SSL cert for an app - https://yourlocalwebguy.dev. I contacted CloudWays support who said “There were some package dependencies that are resolved now” and, in the process, they also installed the SSL certificate for me. That’s all working fine.

I then created a subdomain for yourlocalwebguy.dev in the DNS settings of my domain registrar (GoDaddy). It’s https://ipswichdistrictwelding.yourlocalwebguy.dev/ - I then pointed it to a separate CloudWays app (Wordpress install) and that seems to be working all good, too.

The problem that arises is when I type https://ipswichdistrictwelding.yourlocalwebguy.dev/ into a new tab (in Google Chrome) it comes up with the page saying it’s ‘unsecured’.

So I check the root domain of https://yourlocalwebguy.dev/ and that one works

Then, after loading the root domain, NOW the subdomain loads with the SSL certificate

I want it to be able to load with the SSL in the first place.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://yourlocalwebguy.dev and https://ipswichdistrictwelding.yourlocalwebguy.dev/

I ran this command: I typed it into the search box in Google Chrome

It produced this output: “Your connection is not private”

My web server is (include version): CloudWays, I think.

The operating system my web server runs on is (include version): I have no idea.

My hosting provider, if applicable, is: CloudWays

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know what that is.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): As in cpanel? No.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): I have no idea.

Hi,

According to Cloudway’s support article, I’m afraid you’ll need to get one certificate for each app. (Or at least you’ll need to apply that certificate to the app)

That’s how Cloudway implement their system, and it’s better to contact their support for confirmation…

https://support.cloudways.com/how-to-install-lets-encrypt-ssl-certificate/?utm_source=Platformkb&utm_medium=kbsearch

Thank you

1 Like

Wonderful! Thank you.

I contacted them with what you told me and they helped me through it. I didn’t realise it was something on their end but it turns out I’d misunderstood how “wildcard” works.

Thank you very much for your help.

1 Like

A wildcard works where you can install it. If you can’t install it, it can’t work.

You should get a second domain to separate your front office from your clients pages, and maybe submit that second domain for inclusion in the Public Suffix List, so each client will have their own rate limits even if they don’t buy their own domain name.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.