Want to install certificate in RHEL 6.5

Sir,
I am new in my office and maintaining small website. My boss told me to secure the website through Lets encrypt.
I tried a lot but not able to install the required certificate.
My server confederation are : Linux RHEL 6.5 apache.
I saw many vedio in youtube and the original website and tried to install but all in vein

  1. I tried but No EPEL certificate is installed server .
    (yum -y install epel-release)
    Please guide me how to install the certificate through certbot .

regards
upendra

Hi @upendrajpr

if you want to use a Letsencrypt certificate, then start with the basics.

Then install a client.

Then try to use that client.


There is a template of #help - that’s very helpful:


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Don't. Seriously, don't. Certbot has a mess of dependencies which will be hard (or impossible) to satisfy on RHEL 6. Try the much simpler and more lightweight client of acme.sh instead.

My domain is : rtijaipur.cag.gov.in
My web server apache httpd
operating system is RHEL 6.5
I can login to a root shell on my machine : YES
I am NOT provided any control panel for root shell. I use putty
Till now I don’t have any client

The site

says, that

Certbot-Auto should work with RHEL 6.5.

when I execute the command “yum -y install epel-release” enable the EPEL (Extra Packages for Enterprise Linux) repository no action has been performed. Is it necessary to execute successfully for
next command “wget https://dl.eff.org/certbot-auto

I am trying to execute the command in this order:

yum -y install epel-release

#yum search certbot

yum info certbot (for detail info)

#yum install -y python2-certbot-apache

certbot --apache -d rtijaipur.cag.gov.in

enter info 1. email: rtijaipur@cag.gov.in 2. A 3. 1 4. 2

find /etc/letsencrypt/live

curl https://rtijaipur.cag.gov.in for confirmation

vi /etc/httpd/conf.d/ssl.conf

/SSLProtocol

Insecure:

SSLProtocol all -SSLv2

SSLProtocol all -SSLv2 -SSLv3

Insecure:

#/SSLCipherSuite HIGH:MEDIUM: !aNULL: !MD5:!SEED:!IDEA
SSLCipherSuite EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH

apachectl configtest

syntex ok

systemctl restart httpd

#curl https://rtijaipur.cag.gov.in
#certbot renew

crontab -e

comment #to renew ssl certs daily
0 0 * * * /usr/bin/ certbot renew &>/var/log/certbot.cronlog
:wq
#crontab -l
#service start certbot-renew.servic
#service status certbot-renew.servic

for yum -y install epel-release
the message I got “No package epel-release available error: nothing to do”
for yum install -y python2-certbot-apache
the message I got "No package python2-certbot-apache available error: nothing to do "

Or follow the instructions Juergen linked to--no part of them involve using yum in any way. But seriously, don't use certbot.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.