Virtual Host on port 71


#1

Hello,

I want to install a SSL certificate on my website but i get this error :

Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

My apache server is listening on the port 71. Can I stil install the SSL certificate on my website ?

Thank you in advance.


#2

Authentication must be over port 80.
If you are unable to (also) listen on port 80, you may have to use DNS authentication to obtain the cert - which can be used on any port thereafter.


#3

Thank you @rg305 ,
Can I change temporarily the port on 80 to install the certificate and then reset to my original configuration ?


#4

If your ISP is not blocking port 80 inbound, yes, that should work.
And port 80 is not already being used by anything else…


#5

In fact my apache server is connected to a VPS with a VPN ( the VPS is hosting the VPN server) so the port 80 is already used and I have to use the port 71 instead to acess to my website.
I have no solution ? :confused:


#6

Yes, you do: use DNS validation, as @rg305 mentioned above.


#7

Thanks @danb35 ,

How I am supposed to do this ? The command that I used was only

sudo ./certbot


#8

Hi @C9H13N

check the command line options:

sudo ./certbot --preferred-challenges dns-01

may be enough to start. You have to create a new dns text entry

_acme-challenge.yourdomain.com

with a special value. But if you want to renew the certificate, you have to set a new value.


#9

Yes I think it will solved my problem. But when I run this command I have the following error :

None of the preferred challenges are supported by the selected plugin

I can’t find the command to install the “dns plugin” :neutral_face:


#10

If you want to use the dns-01 - validation and if your dns provider doesn’t support an api, you have to use

--manual

as authenticator. But I don’t know if you install your certificate manual or automatic.

Perhaps you use

certonly

as additional option and install the certificate manual.

I don’t know how certbot handles such a configuration where no standard port 80 is open.


#11

Yep thanks, I have now installed the certificate.

Congratulations! Your certificate and chain have been saved at: /etc/letsencrypt/live/technet.ovh/fullchain.pem

Actually it should work but for some reason I can’t acess to : https://www.technet.ovh


#12

If you use certonly, you have to install the certificate manual.

And: Which port does your installation use? Port 443? Or another port?

Your http works. But http doesn’t answer. Check your firewall.


#13

The traffic is going through different port and 2 different VPN … Now I think I can solve the problem alone.
Thanks a lot @JuergenAuer


#14

Good to know - thanks.


Notification to me:

oh - wonderful - means

Your http works. But https doesn’t answer.


#15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.