Version Conflict


#1

Hi i am getting a version conflict on Certbot
any idea’s would be helpful


#2

try:
find / -name certbot
find / -name certbot-auto
which certbot
which certbot-auto
certbot --version
certbot-auto --version

also the WGET failed…
try forcing IPv4:
wget -4 https://dl.eff.org/certbot-auto


#3

You misspelled certbot-auto in your command as cerbot-auto.


#4

Still getting the same error


#5

Maybe first run rm certbot-auto before doing the wget download?


#6

I tried that like an hr ago =) I am a pretty good command line guy , i am totally stumped


#7

@bmw, in this case should a user just remove the venv in /opt/eff.org before running certbot-auto again?


#8

I’m a little confused how things got into that state. Have you installed packages in Certbot’s virtual environment yourself? Removing /opt/eff.org is certainly a good start to resolving it though.


#9

So the history is the site went thru an upgrade a few weeks back and it looks like when it did. Something got screwed up.

I tried removing /opt/eff.org directory doesn’t exist… Maybe we are looking at this the wrong way and it is looking for that resource ?

Matt


#10

Interesting. I suggest trying the following:

  1. Run grep -m1 LE_AUTO_VERSION /path/to/certbot-auto. If you don’t see LE_AUTO_VERSION=0.22.0, or a newer version number, download a new version of the script from https://dl.eff.org/certbot-auto.
  2. Does echo $VENV_PATH produce any output? If so, unless you know what that environment variable does and what you’re trying to do with certbot-auto, unset the variable.
  3. Run rm -rf ${XDG_DATA_HOME:-~/.local/share}/letsencrypt /opt/eff.org. If you think you may have run certbot-auto as a non-root user in the past, run rm -rf ${XDG_DATA_HOME:-~/.local/share}/letsencrypt as that user as well.
  4. Try running certbot-auto again.

Following those steps should have gotten you in a clean state, but if you’re still getting a similar error message, please post the contents of the file referenced in Certbot’s output where it says “Please see the logfile ‘/tmp/…’ for more details.”


#11

[quote=“bmw, post:10, topic:57033”]
rm -rf ${XDG_DATA_HOME:-~/.local/share}/letsencrypt /opt/eff.org.

Geting problem binding to443 ipv4 or ipv6


#12

Despite there still being a problem, great! It sounds like the version conflict you were having was resolved.

The standalone plugin works by spinning up a temporary server to listen on port 80/443. If you’re already running a server, the webroot plugin might work better for you.


#13

i figured it out … THANK YOU !


#14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.