ValueError: Unable to insert label!


#1

Running # certbot --apache on CentOS7 getting the below error

]# tail -f /var/log/letsencrypt/letsencrypt.log
File “/usr/lib/python2.7/site-packages/certbot_apache/http_01.py”, line 95, in _mod_config
self._set_up_include_directives(vh)
File “/usr/lib/python2.7/site-packages/certbot_apache/http_01.py”, line 170, in _set_up_include_directives
vhost.path, “Include”, self.challenge_conf_pre)
File “/usr/lib/python2.7/site-packages/certbot_apache/parser.py”, line 344, in add_dir_beginning
self.aug.insert(first_dir, “directive”, True)
File “/usr/lib/python2.7/site-packages/augeas.py”, line 369, in insert
raise ValueError(“Unable to insert label!”)
ValueError: Unable to insert label!
2018-02-28 11:35:44,303:ERROR:certbot.log:An unexpected error occurred:


#2

Hi @jndivo,

That’s weird! Could you tell us which version of Certbot (via certbot --version)?


#3

hi, i face the same issue:
the version of my certbot:

certbot --version
certbot 0.21.1

well…i’ve found. confi should contain at least

<VirtualHost *:80>
ServerName yourdomain.com
<//VirtualHost>

I missed ServerName entry with my domain


#4

I’m getting the same error on my first install on Ubuntu 16.04 LTS.
sudo certbot --apache -d subdomain.example.com

Certbot 0.21.1
<VirtualHost _default_:443>
ServerName subdomain.example.com


#5

Hi,

Do you have the same vHost with port 80?

If you don’t, please add it on and try again. (According to @kalyan57


#6

Thanks, once I changed default:443 to *:80 it worked!


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.