Update certbot without snap on ubuntu 20.04

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: mike-r.com

I ran this command:sudo apt-get upgrade certbot

It produced this output:
Reading package lists... Done
Building dependency tree
Reading state information... Done
certbot is already the newest version (0.40.0-1ubuntu0.1).
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

My web server is (include version): Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:myself

I can login to a root shell on my machine (yes or no, or I don't know):yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0
certbot-auto: command not found

Please DO NOT advise me to install or use snap
For several reasons, including speed and disk space usage I do not have snap installed. I have searched for installation instructions using apt or apt-get and found nothing that worked.
The current version of certbot (0.40) appears to work -- is it supported for future use?

The operating system my web server runs on is (include version):

Hi @MikeR,

Who knows, but I wouldn't bet on it.

If you don't want to use another acme client you could install an updated version using pip (read carefully the instructions).

But in this case, as you don't want to use the snap version, I really recommend the use of another client like acme.sh



I second the motion.
The best alternative to snaps is to use acme.sh.
[be aware that it will default to using ZeroSSL CA - must set global parameter to use LE CA]

EDIT: Two other potential possibilities came to mind

  • certbot-docker [if you are into docking things]
  • compile certbot from source code [not sure if this is even an option - but it should be]

I don't agree. While I do not advocate using pip as the first choice, I think it's a good way to install certbot when other methods are not possible or wanted. pip when used in a virtual environment ("venv") as described in the how-to on https://certbot.eff.org/ works nicely.

So if OP wants to keep using certbot, I agree with @sahsanu to use pip.

1 Like

Did I misread?

1 Like



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.