Unexpected error: cannot instantiate ctype 'EVP_MD_CTX' of unknown size

hi folks, I created a certificate (which works and is secure) using the following command:

certbot --apache --keep -d www.rfi.net

When I run a check on it, using “certbot certificates” I get:

Renewal configuration file /etc/letsencrypt/renewal/rfi.net.conf produced an unexpected error: cannot instantiate ctype ‘EVP_MD_CTX’ of unknown size. Skipping

This doesn’t look good for the next renewal attempt… Any ideas?

My best idea would be working with some of your Python dependencies as suggested here: https://github.com/burnash/gspread/issues/407

However that’s just from some quick poking around, so definitely vet those results against your environment.

1 Like

thanks for the response, Jared. I tried this:

pip install cryptography==1.4

and got various compilation areas. I’ve a fairly clean Debian 9 (Stretch) install. Working my way through the missing libs, and installing: libffi-dev, gcc got me to the point where running the pip command above worked cleanly, and apparently I’ve successfully cargo-culted my cryptography to v1.4 Now when I run “certbot certificates” I get a meaningful output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log

Found the following certs:
Certificate Name: rfi.net
Domains: rfi.net,pub.rfi.net,www.rfi.net
Expiry Date: 2017-11-29 08:45:00+00:00 (VALID: 89 days)

So I think this looks good. Many thanks for the tip! :grinning:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.