Unable to run certbot or letsencrypt because of a ValueError (new_authzr_uri)


#1

My certificate expired. I had obtained a certificate last time for www.musicwhim.com
So I figured I could delete the expired certificate and obtain a new one for musicwhim.com without the www. There was some error while creating a new certificate, so I decided to update certbot. After updating, certbot/letsencrypt fails to run at all. I’ve pasted the error below.

My domain is: musicwhim.com

I ran this command: sudo certbot --apache

It produced this output:

Traceback (most recent call last):
  File "/usr/bin/certbot", line 11, in <module>
    load_entry_point('certbot==0.22.2', 'console_scripts', 'certbot')()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 561, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2631, in load_entry_point
    return ep.load()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2291, in load
    return self.resolve()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2297, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python3/dist-packages/certbot/main.py", line 17, in <module>
    from certbot import account
  File "/usr/lib/python3/dist-packages/certbot/account.py", line 122, in <module>
    class RegistrationResourceWithNewAuthzrURI(messages.RegistrationResource):
  File "/usr/local/lib/python3.5/dist-packages/acme/jose/json_util.py", line 181, in __new__
    return abc.ABCMeta.__new__(mcs, name, bases, dikt)
  File "/usr/lib/python3.5/abc.py", line 133, in __new__
    cls = super().__new__(mcls, name, bases, namespace)
ValueError: 'new_authzr_uri' in __slots__ conflicts with class variable

My web server is (include version): apache2

The operating system my web server runs on is (include version): Ubuntu 16.04.4 LTS (xenial)

My hosting provider, if applicable, is: -

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Please show:
certbot --version
certbot certificates
grep -Eri 'servername|serveralias' /etc/apache2

How did you delete the cert?

How did you update certbot?

(since they both go to the same IP)
You can get a cert that holds both names.


#3

I used certbot delete

I completely uninstalled it and then installed it using the steps from the certbot site.

Turns out, there was an older version of certbot installed using pip (probably a long time back) and that was causing this problem.

I just updated this certbot using pip and it seems to be working fine.

Thanks for the help!


#4

You’re welcome.
Please mark the ticket as solved.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.