Unable to renews SSL

My domain is:
ogapp.club

I ran this command:
certbot renew

It produced this output:
it tries to renew my other 3 existing domains that are already renewed

My web server is (include version):
Apache/2.4.18 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 16.04.6 LTS

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.31.0

Earlier after trying force renewing it it made a empty conf file for the domain in /etc/letsencrypt/renewal after that I tried certbot renew again where it showed that the conf file is broken!
There is another domain which like this one doesnt show up in certbot certificates command but the ssl is working for that since it hasn’t expired unlike ogapp which expired last month!

Also something important, the pem files for both the domains that don’t show up were missing so I restored that to keep the site working using this guide


I also had to remake the conf file for ogapp.club in sites-available and enable it manually as it didnt exist there either! This all happened right after the certificate expired!

1 Like

I’m not making heads or tails of your story…

In these lines you’re saying everything has renewed already. I don’t see a problem there.

The fact a certificate expires doesn’t suddenly delete a file from sites-available… Something else must have gone wrong there.

Could you please give us the output of certbot certificates? And if a renewal didn’t work, please share the complete output and contents of letsencrypt.log.

1 Like

This is the output of certbot certificates
Saving debug log to /var/log/letsencrypt/letsencrypt.log

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Found the following certs:
  Certificate Name: bashed.pro
Domains: bashed.pro www.bashed.pro
Expiry Date: 2020-06-03 15:00:27+00:00 (VALID: 30 days)
Certificate Path: /etc/letsencrypt/live/bashed.pro/fullchain.pem
Private Key Path: /etc/letsencrypt/live/bashed.pro/privkey.pem
  Certificate Name: reasy.pro
Domains: reasy.pro www.reasy.pro
Expiry Date: 2020-08-01 12:52:16+00:00 (VALID: 89 days)
Certificate Path: /etc/letsencrypt/live/reasy.pro/fullchain.pem
Private Key Path: /etc/letsencrypt/live/reasy.pro/privkey.pem
  Certificate Name: xpatreonx.store
Domains: xpatreonx.store www.xpatreonx.store
Expiry Date: 2020-06-10 17:01:55+00:00 (VALID: 37 days)
Certificate Path: /etc/letsencrypt/live/xpatreonx.store/fullchain.pem
Private Key Path: /etc/letsencrypt/live/xpatreonx.store/privkey.pem

Pardon my typo I mean the domain that I am trying to renew whose certificate expired is not showing up when in the existing certbot certificates so I could not renew it with certbot renew

Also this is the letsencrypt log file you asked for! https://paste.ubuntu.com/p/9MCc9fDG4k/

I have mostly followed the guides on digitalocean on how to setup ssl for ubuntu

The domain that I am trying to renew my certificate for is ogapp.club which you can see doesn’t exist in the list given by certbot certificates

1 Like

Just posting the solution I found to this.

So I removed the the folder for ogapp.club from /archives then ran
sudo certbot --apache -d ogapp.club
which issued a new certificate, now only had to reload apache config to get the ssl working again

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.