Unable to renew

I
My domain is: properties.fatpalm.com

I ran this command: sudo certbot renew

It produced this output:
tried to renew my already expired certificate and i got into this:

root@hostname:/etc/apt# sudo certbot renew
Bootstrapping dependencies for Debian-based OSes… (you can skip this with --no-bootstrap)
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release
Ign:3 https://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.6 InRelease
Ign:4 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.2 InRelease
Ign:5 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 InRelease
Hit:7 https://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.6 Release
Hit:8 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.2 Release
Hit:9 http://ppa.launchpad.net/certbot/certbot/ubuntu artful InRelease
Hit:10 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 Release
Hit:12 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:14 http://ppa.launchpad.net/ondrej/php/ubuntu artful InRelease
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
ca-certificates is already the newest version (20180409).
openssl is already the newest version (1.1.0g-2ubuntu4).
python is already the newest version (2.7.15~rc1-1).
python set to manually installed.
python-dev is already the newest version (2.7.15~rc1-1).
python-dev set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libssl-dev : Depends: libssl1.1 (= 1.1.0g-2ubuntu4) but 1.1.0h-2.0+ubuntu17.10.1+deb.sury.org+1 is to be installed
E: Unable to correct problems, you have held broken packages.

My web server is (include version): nginx/nodejs

The operating system my web server runs on is (include version): ubuntu 18.04 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

There are apt repositories from 3 different Ubuntu releases. And artful has been EOL for a year.

(One of them is the Certbot PPA, but you're executing certbot-auto, which doesn't use the PPA.)

certbot-auto isn't doing anything weird -- it's just running some apt-get commands to try to ensure some packages are installed.

I'd suggest making sure all the apt repositories are for the right version of Ubuntu -- bionic, you said -- and then see if it works. If not, try posting on an Ubuntu forum, or a community for the PPA at issue, if there is one.

(If you've upgraded to a newer release of Ubuntu, with newer packages, you may not even want to keep all of the PPAs enabled.)

Edit: You may want to consider switching from certbot-auto to the Certbot PPA -- or even the packages from Ubuntu's repositories -- but that's a separate issue from fixing the apt configuration.

2 Likes

thanks for the comments. This actually saved my time. I searched and found a full list of repos that I have just copied and pasted in the server’s list and it worked.
for any one who is looking for it:
https://gist.github.com/h0bbel/4b28ede18d65c3527b11b12fa36aa8d1

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.