Certbot stuck at 0.22.2. How to get to .28?

My domain is: .com

I ran these command: sudo apt-get update sudo apt-get install software-properties-common
sudo add-apt-repository universe sudo add-apt-repository ppa:certbot/certbot
sudo apt-get update sudo apt-get install certbot python-certbot-apache

The first 5 commands succeed as expected.
The last command does not upgrade certbot and produces this output:
Reading package lists… Done
Building dependency tree
Reading state information… Done
python-certbot-apache is already the newest version (0.25.0-2+ubuntu17.10.1+certbot+1).
certbot is already the newest version (0.22.2-1+ubuntu17.10.1+certbot+1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

My web server is Apache 2.4.27

The operating system my web server runs on is Ubuntu 17.1

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.22.2

When I do the dry run everything succeeds.
$ sudo certbot renew --dry-run
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /etc/letsencrypt/renewal/.com.conf

Cert not due for renewal, but simulating renewal for dry run
Plugins selected: Authenticator apache, Installer apache
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for .com
http-01 challenge for www..com
Waiting for verification…
Cleaning up challenges

new certificate deployed with reload of apache server; fullchain is

** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates below have not been saved.)

Congratulations, all renewals succeeded. The following certs have been renewed:
/etc/letsencrypt/live/.com/fullchain.pem (success)
** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates above have not been saved.)

Ubuntu 17.10 is EOL. The Certbot PPA no longer contains new packages for it. :sweat:

You should upgrade to Ubuntu 18.04.


Thanks. I was afraid of that. That’ll be the last time I run anything important on a non-LTS version…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.