Unable to renew certificate - undefined method `[]' for nil:NilClass (NoMethodError)


#1

I am using LetsEncrypt (letsencrypt-webfactio) for over a year now and the renewal is working fine with a cron job. The job ran successfully on 24th May and renewed anothe domain. However, it is failing now with the error shown, I have not made any changes to my config or cron job so far. I suspect this has something to do with recent GDPR changs, but not sure how to fix it. Any inputs, pointers would be highly appreciated.

TIA,

  • Manish

Details below -->

My domain is: orisyssoft.com

I ran this command: letsencrypt_webfaction --config ~/le_conf.yml --domains orisyssoft.com,www.orisyssoft.com --public <application_dir>

It produced this output:

Failed to verify statuses.
<my_home>/.letsencrypt_webfaction/gems/gems/letsencrypt_webfaction-2.0.1/lib/letsencrypt_webfaction/domain_validator.rb:65:in print_error': undefined method[]’ for nil:NilClass (NoMethodError)
from <my_home>/.letsencrypt_webfaction/gems/gems/letsencrypt_webfaction-2.0.1/lib/letsencrypt_webfaction/domain_validator.rb:52:in block in print_errors' from <my_home>/.letsencrypt_webfaction/gems/gems/letsencrypt_webfaction-2.0.1/lib/letsencrypt_webfaction/domain_validator.rb:52:ineach’
from <my_home>/.letsencrypt_webfaction/gems/gems/letsencrypt_webfaction-2.0.1/lib/letsencrypt_webfaction/domain_validator.rb:52:in print_errors' from <my_home>/.letsencrypt_webfaction/gems/gems/letsencrypt_webfaction-2.0.1/lib/letsencrypt_webfaction/domain_validator.rb:21:invalidate!’
from <my_home>/.letsencrypt_webfaction/gems/gems/letsencrypt_webfaction-2.0.1/lib/letsencrypt_webfaction/application.rb:29:in run!' from <my_home>/.letsencrypt_webfaction/gems/gems/letsencrypt_webfaction-2.0.1/exe/letsencrypt_webfaction:5:in<top (required)>’
from <my_home>/.letsencrypt_webfaction/gems/bin/letsencrypt_webfaction:23:in load' from <my_home>/.letsencrypt_webfaction/gems/bin/letsencrypt_webfaction:23:in

My hosting provider, if applicable, is: Webfaction

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


Http-01 challenge failing for alternate requests
#2

Hi,

As I can see, you have already opened an issue at letsencrypt-webfactio’s GitHub… It’s better to ask for answers there. Since this is software problem & the author may not be active in this community.

Thank you


#3

Getting this now: Remote PerformValidation RPCs failed

I did follow up with the owner of letsencrypt_webfaction here and after some digging this is what I am getting for the URL https://acme-staging.api.letsencrypt.org/acme/challenge/7NQhC53da4sqRnMq_gOul05cJY4kMJLvSR06nwQ1FTY/134539789 -

"error": {
    "type": "urn:acme:error:serverInternal",
    "detail": "Remote PerformValidation RPCs failed",
    "status": 500
  },

How do I fix it? Any pointers would be highly appreciated.


#4

@cpu, do you know why this internal error could be happening?


#5

I’ll take a look. Thanks for flagging.


#6

We see a low background level of these errors in the staging environment from the trial multi-VA deployment. Unfortunately we don’t have sufficient logging to identify the root-cause as-is. I’ve filed an issue on Boulder’s repo to try and address this soon: https://github.com/letsencrypt/boulder/issues/3753

In the meantime I believe this is a transient error and @orisyssoft should be able to retry issuance with success.


#7

Tried several times with staging server and it failed with same message every time. So finally tried with production server (https://acme-v01.api.letsencrypt.org/) and that finally worked! :slight_smile:


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.