Unable to reach domain and create certificate (on Synology)

My domain is: Feed-Plex.com

Describe the issue: Synology return me “Failed to connect to Let’s Encrypt. Please make sure the domain name is valid.”

My web server is (include version): Apache 2.4 and PHP 7.3

The operating system my web server runs on (include version) Synology DSM 6.2.3-25426 Update 2 (latest version).

Parameters used to create the certificate:

Domain name: feed-plex.com
E-mail: my own email
Subject alternative names: sonarr.feed-plex.com;radarr.feed-plex.com;jackett.feed-plex.com;feed-plex.com

My hosting provider, if applicable, is OVH (host my domain name and proxies used).

Ports 80 and 443 are open in my router and forward them directly on my Synology. My firewall also contain rules to allow connections using ports 80 and 443.

1 Like

Can you test Global DNS name resolutions on the Synology?
Can you test outbound HTTPS connections from the Synology to the Internet?

Does your firewall have any logs showing the Synology getting out to the Internet for HTTPS?

Hi @GhostPyxel

that doesn’t work. See your checks, ~~ one hour old - https://check-your-website.server-daten.de/?q=feed-plex.com

Domainname Http-Status redirect Sec. G
http://feed-plex.com/ 90.1.166.64 -14 10.000 T
Timeout - The operation has timed out
https://feed-plex.com/ 90.1.166.64 -14 10.020 T
Timeout - The operation has timed out
http://feed-plex.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 90.1.166.64 -14 10.033 T
Timeout - The operation has timed out

Only timeouts.

So you have blocking rules (if curl http://feed-plex.com/ works from that machine) or a wrong / not working router configuration.

“check your website” must be able to see your http port 80. If not, Letsencrypt can’t check your domain.

1 Like

So the problem is solved and came from port 80 who wasn’t redirecting correctly my IPv4 to my Synology (even if the rule was there and valid ?). Deleting the rule and recreating it worked instantly. Thanks for the quick responses and the efficiency guys.

3 Likes

Thanks reporting back. Happy you have found a solution: :+1:

So we know: Sometimes the Synology error message isn’t so good. Looks like your device couldn’t connect Letsencrypt. But that wasn’t the problem.

2 Likes