Unable to install on Ubuntu 19.10

I’m having trouble installing certbot. I’m following the instructions here: https://certbot.eff.org/lets-encrypt/ubuntuother-nginx
I already ran apt-get update and apt-get upgrade before running the command below.

My domain is: irrelevant

I ran this command: sudo apt-get install certbot python-certbot-nginx

It produced this output:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package certbot is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'certbot' has no installation candidate
E: Unable to locate package python-certbot-nginx

My web server is (include version): irrelevant

The operating system my web server runs on is (include version): Ubuntu 19.10

My hosting provider, if applicable, is: irrelevant

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): can’t provide

1 Like

Works for me in a fresh Ubuntu 19.10.

What output do you get from:

apt-cache show certbot

For reference, here’s what mine shows:

root@c0cf5724966a:/# apt-cache show certbot
Package: certbot
Architecture: all
Version: 0.36.0-1
Priority: extra
Section: universe/web
Source: python-certbot
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Let's Encrypt <team+letsencrypt@tracker.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 55
Provides: letsencrypt
Depends: python3-certbot (= 0.36.0-1), python3:any
Suggests: python3-certbot-apache, python3-certbot-nginx, python-certbot-doc
Breaks: letsencrypt (<= 0.6.0)
Replaces: letsencrypt
Filename: pool/universe/p/python-certbot/certbot_0.36.0-1_all.deb
Size: 18084
MD5sum: be8aa2010015d9bece32e5521910f938
SHA1: 4557d017c6f23597ac8756e0ea6d60dbf006d691
SHA256: a704f9c8dd5cd11f64bbbf7cdea2f8643156839c28424ea24f3ba19714c52287
Homepage: https://certbot.eff.org/
Description: automatically configure HTTPS using Let's Encrypt
Description-md5: deb7e404ce1b150b59379c3f9a73ac1a
1 Like

Here’s the output of apt-cache show certbot:

N: Can't select versions from package 'certbot' as it is purely virtual
N: No packages found

Do you have universe enabled?

apt install software-properties-common

followed by:

apt-add-repository universe
1 Like

That fixed it! Not sure what I did to remove universe beforehand.
Thank you! Topic closed.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.