Unable to install Let's Encrypt Certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: oliviergisiger.com

I ran this command: install new certificate

It produced this output: Error in LetsEncrypt::add: An unexpected error occurred:e[0m
e[31mThere were too many requests of a given type :: Error creating new order :: too many certificates (5) already issued for this exact set of domains in the last 168 hours: oliviergisiger.com,staging-2022.oliviergisiger.com: see https://letsencrypt.org/docs/rate-limits/e[0m
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
dockercertbot@int-domu-13:~$

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Infomaniak

I can login to a root shell on my machine (yes or no, or I don't know):no

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Infomaniak Control Panel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hello,

After installing new aliases, I updated the certificate.
The new aliases were not added.
So I uninstalled the certificate.
I tried to install a new certificate but got timeouts.
I tried again and now I have a too many request error message.
How can I install a new certificate?

With kind regards,

Olivier Gisiger

1 Like

You should ask whatever support channels exist for Informaniak how to install one of the five identical certificates you've generated in the past week.

3 Likes

Thanks danb35.
I've just bought a new certificate as I have to launch a new website this week-end.
Kind regards,

2 Likes

Glad you have something working - even if purchased. If you wish to try again some day start with looking at your cert history. There is a large number of certs with a variety of (sub)domain names. Most of these certs have just 1 or 2 names. As @danb35 said, you would have to ask Informaniak how to use their Control Panel to create certs the way you need them.

3 Likes

This error is given when there are already 5 perfectly fine certificates issued for that set of hostnames. In the future, you should just use one of those certificates instead of buying a new certificate.

3 Likes