Unable to Install Certbot on CENTOS 6.8 Due to Dependency Issues


#1

Hi,

I can’t run cerbot due to dependence conflicts:

–> Processing Conflict: httpd24u-tools-2.4.25-3.ius.centos6.x86_64 conflicts httpd-tools < 2.4.25
–> Processing Conflict: 1:httpd24u-mod_ssl-2.4.25-3.ius.centos6.x86_64 conflicts mod_ssl < 1:2.4.25-3.ius.centos6
–> Processing Conflict: httpd24u-2.4.25-3.ius.centos6.x86_64 conflicts httpd < 2.4.25
–> Finished Dependency Resolution
Error: httpd24u-tools conflicts with httpd-tools-2.2.15-39.el6.x86_64
Error: httpd24u conflicts with httpd-2.2.15-39.el6.x86_64
Error: httpd24u-mod_ssl conflicts with 1:mod_ssl-2.2.15-39.el6.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Could not install OS dependencies. Aborting bootstrap!

I don’t want upgrade to Apache 2.4
I have two servers and It’s works fine on an other with Apache 2.2 so why not on this one ?
Can y use --skip-broken somewhere ?

Thanks,
Yann


#2

hi @avalon50

can you explain how you plan to install certbot?
what is your operating system?

Andrei


#3

My OS is CENTOS 6.8
i just followed thes steps :
git clone https://github.com/letsencrypt/letsencrypt /opt/letsencrypt
and ./letsencrypt-auto
and the instal don’t works.


#4

ah ok

there are install scripts which should would work better

review here: https://certbot.eff.org/#centos6-apache

Andrei


#5

Hi,
In fact this script is the same as the one i have.

i use now another script (getssl) and everything is ok.

Thanks.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.