Unable to generate certificate / Failed authorization procedure

hello,

i’m trying to get a certificate via Le’s Encrypt, after a reinstall of the server. But I get an error:

My domain is: bbb.formation-info.fr

I ran this command:

certbot --webroot -w /var/www/bigbluebutton-default/ -d bbb.formation-info.fr certonly

I have tried yet with this command to test:

certbot --dry-run -w /var/www/bigbluebutton-default/ -d bbb.formation-info.fr certonly

It produced this output:

Obtaining a new certificate
Performing the following challenges:
http-01 challenge for bbb.formation-info.fr
Using the webroot path /var/www/bigbluebutton-default for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. bbb.formation-info.fr (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://bbb.formation-info.fr/.well-known/acme-challenge/9-iUILjqEcPIsQHpxGDof1FZ3bcClOT4xTTXK8IfsYg: Connection refused

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: bbb.formation-info.fr
    Type: connection
    Detail: Fetching
    http://bbb.formation-info.fr/.well-known/acme-challenge/9-iUILjqEcPIsQHpxGDof1FZ3bcClOT4xTTXK8IfsYg:
    Connection refused

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): nginx

The operating system my web server runs on is (include version): Ubuntu Server 16.0.4 LTS

My hosting provider, if applicable, is: GANDI

I can login to a root shell on my machine (yes or no, or I don’t know): YES

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.27.0

Thanks a lot for your help

your webserver doesn’t accept connections on port 80.

you have two options:

  • configure your server to accept connections on port 80
  • move from --webroot to --standalone

(in both cases, make sure your firewall is open on port 80)

Hi @Flitox

there

is your error: You need a working webserver. Instead - Connection refused.

There is a check of your domain, created 01:29 - https://check-your-website.server-daten.de/?q=bbb.formation-info.fr

Same - Grade V.

A working port 80 is required. May be a firewall, may another blocking instance.