Failed Authorization Procedure


Hello Everyone,

Hope someone can help us on this. We are new to Certbot and having issues while creating a new SSL Certs.

My domain is:

I ran this command:
./certbot-auto --apache

It produced this output:
Performing the following challenges:
http-01 challenge for
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching Error getting validation data

My web server is (include version): Apache/2.2.15 (Unix)

The operating system my web server runs on is (include version): CentOS release 6.8 (Final)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 0.31.0



Could you try with:

--dry-run --debug-challenges -v

and then upload your /var/log/letsencrypt/letsencrypt.log somewhere (like


The good news is that port 80 is open.

The bad news is that port 80 and port 443 return very different content:

File downloaded from:
-rw-r–r-- 1 root root 9113 Sep 10 02:38 index.html

File downloaded from:
-rw-r–r-- 1 root root 131428 Feb 15 00:18 index.html

So it would seem that perhaps they are not using the same document root ?


I’m a new user and I can’t upload a file. There are too many links on the logs and i can only post up to 20 links. I’m checking for other options to provide the logs.


My bad. Please click this link for the logs:


Hi @alwin.soria

the error:

Type:   connection
Detail: Fetching 
Connection reset by peer

Certbot creates a directory

         <Directory /var/lib/letsencrypt/http_challenges>
            Order Allow,Deny
            Allow from all
        <Location /.well-known/acme-challenge>
            Order Allow,Deny
            Allow from all

and a redirect rule:

RewriteEngine on
RewriteRule ^/\.well-known/acme-challenge/([A-Za-z0-9-_=]+)$ /var/lib/letsencrypt/http_challenges/$1 [L]

But that doesn’t work.

Checking your domain direct ( ):

Domainname Http-Status redirect Sec. G 200 0.327 H 200 0.313 H 301 3.217 N
Certificate error: RemoteCertificateNameMismatch 301 3.393 N
Certificate error: RemoteCertificateNameMismatch 200 8.720 B 404 0.344 A
Not Found 404 0.313 A
Not Found

That looks ok. /.well-known/acme-challenge/unknown-file is open, both domains send the expected http status 404 / Not found.

So try to find your DocumentRoot. Then use it:

certbot run -a webroot -i apache -w yourDocumentRoot -d -d


Thank you so much! That works like a charm!!

closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.