Unable to Find Virtual Host Error on Install

My domain is: robjvargas.com

I ran this command: sudo certbot --apache

It produced this output: PluginError: Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80

My web server is (include version):Apache/2.4.6 (CentOS)

The operating system my web server runs on is (include version): CentOS Linux 7 (Core)

My hosting provider, if applicable, is: Self-managed VPS (HudsonValleyHost)

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

sudo yum install certbot-apache went fine. I got the above error.

NOTE: I previously tried this, and wound up with a host self-signed certificate. I uninstalled via yum at that time. My site, www.robjvargas.com, is reachable via HTTP.

I saved a copy of the output in my OneDrive: https://1drv.ms/u/s!Ah5cuqxY7Lmrj8ETgUBU4j3uCuy2QQ

Oh, I forgot. I’m using Joomla CMS and have it in maintenance mode. I’ll “activate” the site and see what happens…

Nope. Error didn’t change. Standing by.

While that’s definitely one issue, a bigger one is that I can’t even seem to resolve your domain name. At the very least, you’ll need to get DNS set up before you can do anything.

1 Like

Hmm… I opted for basic DNS via my registrar. My A record for www works. I didn’t think to look at the broader domain record.

I just refreshed the settings there. I’ll give it some time to propagate.

Are you trying to issue a certificate for the domain itself, the www. subdomain, or both?

Ideally, both the domain and the Web site (www). This was partly an exercise in getting to know Linux, but the site will be a blog once I get some more configuring done.

Hi @RobJVargas,

If you added an A record for robjvargas.com 2 hours ago, then you need to re-check what you did because your authoritative dns servers don't provide the new A record for robjvargas.com and they should.

Cheers,
sahsanu

2 Likes

See, this is what happens when I build things from the ground up. I learn things that I had never configured before. In this case, according to my registrar, I needed a CNAME record. I didn’t have one. As I said previously, I created an A record for www.

So… done. I’ll give it a few hours to propagate.

You don’t need a CNAME - an A record would work just fine as well. Usually, you’ll specify the base domain (robjvargas.com) as ‘@’, like you specify www.robjvargas.com as ‘www’ when creating the records.

1 Like

Okay, got past this issue. DNS updated, and I needed to create a virtual host (NOTE! there is no such thing as ServierAlias. LOL)

@jared.m: understood that I don’t need CNAME. That’s why I reported that my registrar said that. Still, DNS looks configured. I’ll leave it as long as it’s not causing problems (I don’t anticipate any).

I have a new problem. This one’s my fault. I mentioned up-thread that I changed my hostname after uninstalling certbot. But the original hostname cert is still in effect.

For now, I know certbot and SSL are working. I’ll tackle the “new” problem tonight or tomorrow.

Thanks, everyone.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.