Certbot on apache unable to find virtual host listening on port 80

Hello, I'm trying to setup certbot but get an error that I'm not sure how to fix. Here's the info I'm supposed to give:

My domain is: jomity.net

I ran this command: sudo certbot --apache

It produced this output:
Please enter the domain name(s) you would like on your certificate (comma and/or
space separated) (Enter 'c' to cancel): jomity.net
Requesting a certificate for jomity.net
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

My web server is: Apache/2.4.48

The operating system my web server runs on is: Ubuntu 21.10

My hosting provider, if applicable, is: Contabo

I can login to a root shell on my machine: Yes

I'm using a control panel to manage my site: no

The version of my client is: certbot 1.22.0

Ok.. so I ran the command "sudo a2ensite 000-default," reloaded apache2, and now it seems to work. I think I have HTTPS. However, I'm now getting 403 Forbidden messages on my website. I didn't run any other commands...

1 Like

Yes, you do :slight_smile:

You should check your VirtualHost definition for why you are denying requests. It is not related to your new certs - they seem to be fine. See a site like this:
https://decoder.link/sslchecker/jomity.net/443

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.