Unable to create certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.pulianilawbooks.com

I ran this command:sudo /usr/local/bin/certbot-auto --nginx

It produced this output:

Domain: pulianilawbooks.com
Type: unauthorized
Detail: Invalid response from
http://pulianilawbooks.com/.well-known/acme-challenge/ko5V3mAZZr_RUU_7bF8A2kAokUwGjAV9yQWl256RTP4
[52.74.24.193]: "<!doctype html >\n\n<!–[if IE 7]>

<html clas"

Domain: www.pulianilawbooks.com
Type: unauthorized
Detail: Invalid response from
http://www.pulianilawbooks.com/.well-known/acme-challenge/fKMnOVKexvOURnkNVR6PgP0msjtiB93iw4IAAA_LjqM
[52.74.24.193]: "<!doctype html >\n\n<!–[if IE 7]>

<html clas"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain

My web server is (include version):

The operating system my web server runs on is (include version): Ubuntu

My hosting provider, if applicable, is: name.com

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @karnprem90

your configuration looks buggy - the check - https://check-your-website.server-daten.de/?q=pulianilawbooks.com - runs 20 minutes and isn’t ready. Is there a bot detection that blocks? Looks like all css/js files have a timeout.

What says

nginx -T

Crt.sh has one new certificate, created today - but doesn’t show the details of that certificate.

PS: Now the certificate is visible:

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2019-09-01 2019-11-30 pulianilawbooks.com, www.pulianilawbooks.com - 2 entries duplicate nr. 1

So it has both domain names - non-www and www -, certificate creation has worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.