Error creating ssl certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: detoxlab.com

I ran this command: certbot --nginx -d detoxlab.com -d www.detoxlab.com

It produced this output:
Challenge failed for domain detoxlab.com
Challenge failed for domain www.detoxlab.com
http-01 challenge for detoxlab.com
http-01 challenge for www.detoxlab.com
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

My web server is (include version): nginx 1.18.0

The operating system my web server runs on is (include version): ubuntu 20

My hosting provider, if applicable, is: aws

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

My domain provider is namecheap

I found similar questions here about this problem but none of them work

Hello @ahtisham,

Are you sure? Because seems you are using Apache on CentOS.

$ curl -IkL detoxlab.com
HTTP/1.1 200 OK
Date: Sun, 17 Oct 2021 07:58:50 GMT
Server: Apache/2.2.15 (CentOS)
X-Powered-By: PHP/5.3.3
Connection: close
Content-Type: text/html; charset=UTF-8

Cheers,
sahsanu

2 Likes

No i am sure that configuration is of my old instance that i deleted but i have never used PHP something is wrong with curl :sweat_smile:

curl is working fine :wink: The problem is that your domain is reaching the parking page at turkticaret.net so it is not pointing to your server and you should fix that before trying to issue a certificate.

1 Like

Also, doesn't seem your domain registrar is namecheap...

But i can access the site fine with http it doesn't point to turkticaret.net.

I linked my nameserver of aws with namecheap couple of hours ago myself.

everything seems to working fine except the ssl

Believe me, it doesn't work at all.

I tried to reach your site from Spain, England, Germany and France and I always reach the turkticaret.net's parking page.

The whois for your domain doesn't show namecheap as your registrar:

$ whois detoxlab.com
   Domain Name: DETOXLAB.COM
   Registry Domain ID: 1646205033_DOMAIN_COM-VRSN
   Registrar WHOIS Server: whois.reg2c.com
   Registrar URL: http://www.reg2c.com
   Updated Date: 2021-03-11T14:38:08Z
   Creation Date: 2011-03-18T22:51:21Z
   Registry Expiry Date: 2022-03-18T22:51:21Z
   Registrar: Reg2C.com Inc.
   Registrar IANA ID: 819
   Registrar Abuse Contact Email: abuse@reg2c.com
   Registrar Abuse Contact Phone: 0902242248640
   Domain Status: clientTransferProhibited https://icann.org/epp#clientTransferProhibited
   Name Server: NS1.TURKTICARET.NET
   Name Server: NS2.TURKTICARET.NET
   Name Server: NS3.TURKTICARET.NET
   DNSSEC: unsigned
   URL of the ICANN Whois Inaccuracy Complaint Form: https://www.icann.org/wicf/
>>> Last update of whois database: 2021-10-17T06:28:38Z <<<

The DNS are pointing to turkticaret:

$ dig ns detoxlab.com +short
ns1.turkticaret.net.

And the current ip used by your domain (31.186.11.254) is a turkticare ip.

$ whois 31.186.11.254
[...]
inetnum:        31.186.11.0 - 31.186.11.255
netname:        VODAFONE-WSHS1
country:        TR
admin-c:        VC5385-RIPE
tech-c:         VC5385-RIPE
status:         ASSIGNED PA
mnt-by:         TURKTICARET-MNT
created:        2017-02-15T15:31:21Z
last-modified:  2021-03-01T08:22:23Z
source:         RIPE
[...]

I don't know how you are reaching your site, maybe you have override the ip in your hosts configuration or you are accessing via proxy or vpn... the thing is the rest of the world can't reach your site so something in your dns and or registrar changes is not working fine... maybe it needs more time to propagate changes... but for com domains these changes are performed in a few minutes.

Cheers,
sahsanu

4 Likes

I don't know what i was thinking when i was creating the certificate it was thdetoxlab.com rather than detoxlab.com :man_facepalming:

1 Like

Hehe, things happen :wink:

I'm glad you finally issued the certificate for your domain thedetoxlab.com

Cheers,
sahsanu

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.