Unable to add second domain name

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: lioville.ddns.net

I ran this command: sudo certbot --apache -d lioville.ddns.net -d lioville.net

It produced this output: Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA

My web server is (include version): Apache

The operating system my web server runs on is (include version): Ubuntu

My hosting provider, if applicable, is: My own

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


What’s your certbot version?

Please run sudo certbot --version and share us the results.

Thank you

Please see

Hi thanks for your reply it said certbot 0.19.0

I did read that but I am using Apache rather than NGIX

Right at the bottom of @jsha's post, it says

If you are using Apache, replace --installer nginx in the above commands with --installer apache

The post also describes how upgrading to a newer version of Certbot would allow you to use --apache like you originally tried to do.

Sorry Schoen

Very new here, unsure which other part I have to change? That is the reason why I did not go through with this code.

sudo certbot --authenticator webroot --installer apache
–webroot-path -d

I tried sudo certbot --authenticator webroot --installer apache /var/www/html -d lioville.net does not work

It said unrecognized arguments : /var/www/html

Sorry finally got it to work, but my new domain lioville.net is still not going to https?

Hi @jameslio

now there is no active website. Check your webserver configuration, if your website is running.

Now you have two correct certificates, created today.


With the correct names


You may change the configuration of lioville.net manual, so that lioville.net uses the same certificate as lioville.ddns.net

PS: One thing was wrong: lioville.ddns.net doesn’t use the new certificate. So you have to change both ssl-sections.

Check your current certificates with

certbot certificates

to find the path of the correct certificate.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.