Sudo certbot does not work

install letsencrypt like this a few months ago, like this:

sudo apt-get install software-properties-common python-software-properties
sudo add-apt-repository ppa: certbot / certbot
sudo apt-get update
sudo apt-get install python-certbot-apache

and it worked perfectly for my 10 domains. Currently the domains are renewed without problems. But the new domains when doing:
sudo certbot --apache -d -d

I get this message:
Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA

but with the other domains it worked.

What commands should I use now for new domains ?:

sudo certbot --authenticator webroot --installer apache --webroot-path /var/www/ -d -d

sudo certbot --authenticator webroot --installer apache --webroot-path /var/www/ -d -d

apache \ vs apache \

Should work fine.


See also

What OS are you on?

What version of Certbot are you using?

Apache/2.4.18 (Ubuntu 16.04)

How to know the certbot version?
Any command?

Each user says one thing. I do not know what to choose. I need the exact command for apache.

an effective response. This solved my problem. many thanks !!!
thanks _az

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.