Two different domains, common name is same

My domain is:
aftermath.no
I ran this command:

It produced this output:

My web server is (include version):
nginx/1.14.2
The operating system my web server runs on is (include version):
Debian 10
My hosting provider, if applicable, is:
Linode
I can login to a root shell on my machine (yes or no, or I don't know):
Yes
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
No
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
1.29.0

Hi. I have two domains on my server. mareritt.no and aftermath.no.
Hi. I installed certs for both, but when I check

The common name resolves to mareritt.no

I've been googling and reading for a couple of days now, but can't find a situation quite like this.
I deleted both certs, and reinstalled them, but I got the same result.
So I'm hoping someone here has an idea?

Welcome to the community @Tjukken

Yes, for some reason your nginx server is sending out the below cert for requests to https://aftermath.no. This is a problem in your nginx config.

Common Name:	mareritt.no
SANs:	
DNS:mareritt.no
DNS:www.mareritt.no

The easiest way forward is for you to show us the output of this command: nginx -T

Please put 3 backticks before and after the output like this:
```
output of: nginx -T
```
Use sudo nginx -T if required

4 Likes

I wasn't sure if you wanted it all, but I pasted it none the less.

# configuration file /etc/nginx/nginx.conf:
user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
	worker_connections 768;
	# multi_accept on;
}

http {

	##
	# Basic Settings
	##

	sendfile on;
	tcp_nopush on;
	tcp_nodelay on;
	keepalive_timeout 65;
	types_hash_max_size 2048;
	# server_tokens off;

	server_names_hash_bucket_size 64;
	# server_name_in_redirect off;

	include /etc/nginx/mime.types;
	default_type application/octet-stream;

	##
	# SSL Settings
	##

	ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
	ssl_prefer_server_ciphers on;

	##
	# Logging Settings
	##

	access_log /var/log/nginx/access.log;
	error_log /var/log/nginx/error.log;

	##
	# Gzip Settings
	##

	gzip on;

	# gzip_vary on;
	# gzip_proxied any;
	# gzip_comp_level 6;
	# gzip_buffers 16 8k;
	# gzip_http_version 1.1;
	# gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

	##
	# Virtual Host Configs
	##

	include /etc/nginx/conf.d/*.conf;
	include /etc/nginx/sites-enabled/*;
}


#mail {
#	# See sample authentication script at:
#	# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
# 
#	# auth_http localhost/auth.php;
#	# pop3_capabilities "TOP" "USER";
#	# imap_capabilities "IMAP4rev1" "UIDPLUS";
# 
#	server {
#		listen     localhost:110;
#		protocol   pop3;
#		proxy      on;
#	}
# 
#	server {
#		listen     localhost:143;
#		protocol   imap;
#		proxy      on;
#	}
#}

# configuration file /etc/nginx/modules-enabled/50-mod-http-auth-pam.conf:
load_module modules/ngx_http_auth_pam_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-dav-ext.conf:
load_module modules/ngx_http_dav_ext_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-echo.conf:
load_module modules/ngx_http_echo_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-geoip.conf:
load_module modules/ngx_http_geoip_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-image-filter.conf:
load_module modules/ngx_http_image_filter_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-subs-filter.conf:
load_module modules/ngx_http_subs_filter_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-upstream-fair.conf:
load_module modules/ngx_http_upstream_fair_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-xslt-filter.conf:
load_module modules/ngx_http_xslt_filter_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-mail.conf:
load_module modules/ngx_mail_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-stream.conf:
load_module modules/ngx_stream_module.so;

# configuration file /etc/nginx/mime.types:

types {
    text/html                             html htm shtml;
    text/css                              css;
    text/xml                              xml;
    image/gif                             gif;
    image/jpeg                            jpeg jpg;
    application/javascript                js;
    application/atom+xml                  atom;
    application/rss+xml                   rss;

    text/mathml                           mml;
    text/plain                            txt;
    text/vnd.sun.j2me.app-descriptor      jad;
    text/vnd.wap.wml                      wml;
    text/x-component                      htc;

    image/png                             png;
    image/tiff                            tif tiff;
    image/vnd.wap.wbmp                    wbmp;
    image/x-icon                          ico;
    image/x-jng                           jng;
    image/x-ms-bmp                        bmp;
    image/svg+xml                         svg svgz;
    image/webp                            webp;

    application/font-woff                 woff;
    application/java-archive              jar war ear;
    application/json                      json;
    application/mac-binhex40              hqx;
    application/msword                    doc;
    application/pdf                       pdf;
    application/postscript                ps eps ai;
    application/rtf                       rtf;
    application/vnd.apple.mpegurl         m3u8;
    application/vnd.ms-excel              xls;
    application/vnd.ms-fontobject         eot;
    application/vnd.ms-powerpoint         ppt;
    application/vnd.wap.wmlc              wmlc;
    application/vnd.google-earth.kml+xml  kml;
    application/vnd.google-earth.kmz      kmz;
    application/x-7z-compressed           7z;
    application/x-cocoa                   cco;
    application/x-java-archive-diff       jardiff;
    application/x-java-jnlp-file          jnlp;
    application/x-makeself                run;
    application/x-perl                    pl pm;
    application/x-pilot                   prc pdb;
    application/x-rar-compressed          rar;
    application/x-redhat-package-manager  rpm;
    application/x-sea                     sea;
    application/x-shockwave-flash         swf;
    application/x-stuffit                 sit;
    application/x-tcl                     tcl tk;
    application/x-x509-ca-cert            der pem crt;
    application/x-xpinstall               xpi;
    application/xhtml+xml                 xhtml;
    application/xspf+xml                  xspf;
    application/zip                       zip;

    application/octet-stream              bin exe dll;
    application/octet-stream              deb;
    application/octet-stream              dmg;
    application/octet-stream              iso img;
    application/octet-stream              msi msp msm;

    application/vnd.openxmlformats-officedocument.wordprocessingml.document    docx;
    application/vnd.openxmlformats-officedocument.spreadsheetml.sheet          xlsx;
    application/vnd.openxmlformats-officedocument.presentationml.presentation  pptx;

    audio/midi                            mid midi kar;
    audio/mpeg                            mp3;
    audio/ogg                             ogg;
    audio/x-m4a                           m4a;
    audio/x-realaudio                     ra;

    video/3gpp                            3gpp 3gp;
    video/mp2t                            ts;
    video/mp4                             mp4;
    video/mpeg                            mpeg mpg;
    video/quicktime                       mov;
    video/webm                            webm;
    video/x-flv                           flv;
    video/x-m4v                           m4v;
    video/x-mng                           mng;
    video/x-ms-asf                        asx asf;
    video/x-ms-wmv                        wmv;
    video/x-msvideo                       avi;
}

# configuration file /etc/nginx/sites-enabled/aftermath.no:
server {
        listen 80;
        listen [::]:80;
	root /var/www/aftermath.no;
	index index.html index.htm;
        server_name aftermath.no www.aftermath.no;

	location / {
	try_files $uri $uri/ =404;
}

}

# configuration file /etc/nginx/sites-enabled/default:
##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# https://www.nginx.com/resources/wiki/start/
# https://www.nginx.com/resources/wiki/start/topics/tutorials/config_pitfalls/
# https://wiki.debian.org/Nginx/DirectoryStructure
#
# In most cases, administrators will remove this file from sites-enabled/ and
# leave it as reference inside of sites-available where it will continue to be
# updated by the nginx packaging team.
#
# This file will automatically load configuration files provided by other
# applications, such as Drupal or Wordpress. These applications will be made
# available underneath a path with that package name, such as /drupal8.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

# Default server configuration
#
server {
	listen 80 default_server;
	listen [::]:80 default_server;

	# SSL configuration
	#
	# listen 443 ssl default_server;
	# listen [::]:443 ssl default_server;
	#
	# Note: You should disable gzip for SSL traffic.
	# See: https://bugs.debian.org/773332
	#
	# Read up on ssl_ciphers to ensure a secure configuration.
	# See: https://bugs.debian.org/765782
	#
	# Self signed certs generated by the ssl-cert package
	# Don't use them in a production server!
	#
	# include snippets/snakeoil.conf;

	root /var/www/html;

	# Add index.php to the list if you are using PHP
	index index.html index.htm index.nginx-debian.html;

	server_name _;

	location / {
		# First attempt to serve request as file, then
		# as directory, then fall back to displaying a 404.
		try_files $uri $uri/ =404;
	}

	# pass PHP scripts to FastCGI server
	#
	#location ~ \.php$ {
	#	include snippets/fastcgi-php.conf;
	#
	#	# With php-fpm (or other unix sockets):
	#	fastcgi_pass unix:/run/php/php7.3-fpm.sock;
	#	# With php-cgi (or other tcp sockets):
	#	fastcgi_pass 127.0.0.1:9000;
	#}

	# deny access to .htaccess files, if Apache's document root
	# concurs with nginx's one
	#
	#location ~ /\.ht {
	#	deny all;
	#}
}


# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#
#server {
#	listen 80;
#	listen [::]:80;
#
#	server_name example.com;
#
#	root /var/www/example.com;
#	index index.html;
#
#	location / {
#		try_files $uri $uri/ =404;
#	}
#}

# configuration file /etc/nginx/sites-enabled/mareritt.no:
server {
        listen 80;
        listen [::]:80;
        root /var/www/mareritt.no;
        index index.html index.htm;
        server_name mareritt.no www.mareritt.no;

        location / {
        try_files $uri $uri/ =404;
}

}

# configuration file /etc/nginx/sites-enabled/steelwinter.no:
server {
        listen 80;
        listen [::]:80;
        root /var/www/steelwinter.no;
        index index.html index.htm;
        server_name steelwinter.no www.steelwinter.no;

        location / {
        try_files $uri $uri/ =404;
}

}


Yes, I wanted to see it all. Usually this kind of problem is something wrong with your server blocks using wrong or missing names.

And, something odd is that you do not have ANY server blocks configured for ssl. Each domain name should have one that includes a listen for port 443 and the ssl certificate definitions. But, yours doesn't have any. In fact, I don't understand how your server sends out any certs because none are defined.

Are you sure that this nginx is the one receiving requests? Do you have a router that maybe does port forwarding to a different server? Or, does your DNS point to a different server?

4 Likes

I'm sure. But I do have separate files under sites-available, such as

server {
        listen 80;
        listen [::]:80;
        root /var/www/aftermath.no;
        index index.html index.htm;
        server_name aftermath.no www.aftermath.no;

        location / {
        try_files $uri $uri/ =404;
}

}

These are linked to sites-enabled.
But there's no 443 here either.

Where is the server block that is handling port 443?

3 Likes

I'd like to know that as well. :slight_smile:

Can you show us outputs of these

sudo systemctl status nginx
sudo ps -eF | grep nginx | grep -v grep

and this:

sudo netstat -pant | grep nginx
4 Likes
systemctl status nginx:

nginx.service - A high performance web server and a reverse proxy server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2022-07-24 15:43:10 UTC; 2 days ago
     Docs: man:nginx(8)
  Process: 2940 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
  Process: 2941 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
 Main PID: 2942 (nginx)
    Tasks: 2 (limit: 2359)
   Memory: 3.7M
   CGroup: /system.slice/nginx.service
           ├─2942 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
           └─2944 nginx: worker process

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
ps -eF | grep nginx | grep -v grep
root      2942     1  0 18647  1852   0 Jul24 ?        00:00:00 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
www-data  2944  2942  0 18718  8920   0 Jul24 ?        00:00:02 nginx: worker process

Couldn't find or install netstat. Isn't that a Windows thing?

Yes, but also a Linux thing too.

Try:
sudo apt install net-tools

3 Likes

Aha, OK. Then:

netstat -pant | grep nginx
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      2942/nginx: master  
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      2942/nginx: master  
tcp6       0      0 :::80                   :::*                    LISTEN      2942/nginx: master  
tcp6       0      0 :::443                  :::*                    LISTEN      2942/nginx: master

It doesn't make sense:

  • netstat shows nginx is running on port 80 and 443
  • nginx -T shows only listen 80 [nothing for port 443]
3 Likes

Hmm, I think I should nuke the server and set it up again. Hopefully that should take care of it.

Thanks a lot, guys! I appreciate your efforts!

1 Like

@Tjukken Sorry, been away.

Looks like you are still working on it - all ports are closed now.

But, before, requests to that domain just returned a file kjop.jpg which only said, in Norwegian:

ettersporsel om kjop av domenet; dom@(email domain .st)
(exact chars not typed)

Which, in English is something like:
inquiry about the purchase of the domain; dom@(email domain .st)

Is that helpful? To me it looks like a landing page and not a custom nginx server.

4 Likes

I did nuke my server and apparently it helped, because I've set up several sites with certs and it worked. That domain is actually for sale. I have owned it for many years, but haven't used it for anything. The landing page is just something I set up so it didn't land on my registrar's ad filled pages. I'll do better later. :grinning:

2 Likes