Trying to resolve TOO Many Redirects

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: tmgprojects.ca

I ran this command:

It produced this output: ERR Too many redirects

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: KOS

I can login to a root shell on my machine (yes or no, or I don't know): I think so

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Welcome @Adoom74

I am not sure how this relates to Let's Encrypt certs specifically but you have a loop in your redirects. Something wrong in your Apache, Plesk or Wordpress config.

This is what is happening. Note the www domain redirects to the apex domain which redirects back to www domain forever.

curl -I https://www.tmgprojects.ca
HTTP/1.1 301 Moved Permanently
Date: Sun, 13 Feb 2022 18:15:11 GMT
Server: Apache
X-Powered-By: PHP/7.3.20
X-Redirect-By: WordPress
Location: https://tmgprojects.ca/
X-Powered-By: PleskLin
Content-Type: text/html; charset=UTF-8

curl -I https://tmgprojects.ca
HTTP/1.1 301 Moved Permanently
Date: Sun, 13 Feb 2022 18:15:19 GMT
Server: Apache
Location: https://www.tmgprojects.ca/
Content-Type: text/html; charset=iso-8859-1

curl -I https://www.tmgprojects.ca
HTTP/1.1 301 Moved Permanently
Date: Sun, 13 Feb 2022 18:15:56 GMT
Server: Apache
X-Powered-By: PHP/7.3.20
X-Redirect-By: WordPress
Location: https://tmgprojects.ca/
X-Powered-By: PleskLin
Content-Type: text/html; charset=UTF-8
3 Likes

Thank you @MikeMcQ
I made a change to the Let's Encrypt settings, specifically the "preferred domain" and suddenly the site is working, with the HTTPS... so I'm guessing (nay, HOPING) that the site is live and ok.

1 Like

Hi @Adoom74

Looks like @MikeMcQ helped straighten out your redirects. :face_with_peeking_eye:

style="background-image:url(http://tmgprojects.ca/new/wp-content/uploads/2021/03/2009-Goldstrike-1012-1.jpg)

I am getting mixed content warnings when I visit your site.

tmg

Images, etc. (ALL CONTENT) should be served over https to clear the warning.
In wordpress one would go to settings > permalinks and verify your site url is serving https://tmgprojects.ca/
Someone will correct me if I am in error, but I think thats all that is needed to solve your mixed content issue.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.