Trying to renew certificate, Cerbot Expired Please Help

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: manna167995195books.com.ng

I ran this command: certbot renew --cert-name manna167995195books.com.ng

It produced this output: All renewal attempts failed the following certificate could not be renewed

My web server is (include version):
Ubuntu 18.04.2 x64

The operating system my web server runs on is (include version):
Ubuntu 18.04.2 x64

My hosting provider, if applicable, is: Digitalocean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes, putty

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):0.31.0

Please paste Certbot’s complete output.

I cant seem to copy the text, but heres the image

The “failed authorizations” rate limit will reset in an hour. And if you’d use SSH to connect to your server rather than Digital Ocean’s console, you’d be able to copy/paste.

Hi @aceyosef

there is a check of your domain, ~~ 2 hours old - https://check-your-website.server-daten.de/?q=manna167995195books.com.ng

There you see the problem:

Domainname Http-Status redirect Sec. G
http://manna167995195books.com.ng/
167.99.5.195 301 https://example.com/ 0.206 E
https://manna167995195books.com.ng/
167.99.5.195 200 1.346 N
Certificate error: RemoteCertificateChainErrors
https://example.com/ 200 1.320 B
http://manna167995195books.com.ng/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
167.99.5.195 301 https://example.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 0.207 E
Visible Content: 301 Moved Permanently nginx/1.14.0 (Ubuntu)
https://example.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 404 1.336 A
Not Found

You use webroot, so your current configuration is used.

But you have a redirect http + yourdomain -> https + example.com. So Letsencrypt checks a file from

 https://example.com/.well-known/acme-challenge/random-filename

that can’t work.

Remove that redirect.

Hi JuergenAuer,
Thanks for your reply. I tried and couldn’t get in touch with the developer that installed the certificate to remove the redirection.
I would be grateful for some direction on how this redirection was created and how to remove it.
Thanks once again for your assistance.

Rechecked your domain, there is a nginx.

What says

nginx -T

There should be a vHost definition with the example redirect.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.