Trying to get Let's Encrypt to work on VPS InMotion Hosting


#1

Hi all,

I need help in getting Let’s Encrypt to work on my VPS InMotion Hosting server.

When accessing root and going through the Certbot process on my InMotion Hosting provider using Centos 6.7 Apache, I get the follow error before installation is completed and then me trying to run the ./certbot-auto command

/root/.local/share/letsencrypt/lib/python2.6/site-packages/cryptography/init.py:26: DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of cryptography will drop support for Python 2.6
DeprecationWarning
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Failed to find apachectl in PATH: /usr/local/jdk/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/opt/cpanel/composer/bin:/usr/local/easy/bin:/usr/local/bin:/usr/X11R6/bin:/root/bin
/root/.local/share/letsencrypt/lib/python2.6/site-packages/certbot/main.py:568: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
return e.message
Certbot doesn’t know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run “certbot-auto certonly” to do so. You’ll need to manually configure your web server to use the resulting certificate.
root@server [~]#

Any idea how to fix?

Thanks


#2

There are a couple of options here.

  1. You can use one of the alternate clients some of which ( like the bash ones) have much fewer dependencies, so should work fine.

  2. You could upgrade your python to 2.7 (but this isn’t trivial on CentOS 6)

  3. you can try using certbot in “certonly” mode - as suggested - which may give a few python warnings but should generally work.

Which route would you like to try ?


#3

Hi Serverco,

Thanks for the response.

I think I like to try the #3 route.

However, I will probably ask hosting provider to upgrade to python 2.7 for me in the future.

I’m actually stuck at this juncture now. I entered a few domain names and now it is asking me for the webroot.

Select the webroot for www.polllife.com:

1: Enter a new webroot

Press 1 [enter] to confirm the selection (press ‘c’ to cancel): 1
Input the webroot for www.polllife.com: (Enter ‘c’ to cancel):

What should be entered here?

Thanks,


#4

Your webroot is the location of the “index” file for your website. typically this would be /var/www/ or /home/user/public_html/ it depends how you have your system setup. Where do you place files for them to show up on your website ?


#5

thanks for the info, thought it was that, but wanted to be sure.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.