Trouble renewing cert - no webroot?

Trouble renewing cert - no webroot?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:
/usr/local/bin/certbot-auto certonly -d --nginx
It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Using default address 80 for authentication.
nginx: [warn] duplicate MIME type “text/html” in /etc/nginx/nginx.conf:32
Waiting for verification…
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
nginx: [warn] duplicate MIME type “text/html” in /etc/nginx/nginx.conf:30
Some challenges have failed.



Not Found

\r\n”To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

My web server is (include version):
The operating system my web server runs on is (include version):
centos 7
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 1.6.0

It’s pretty hard to help you with a redacted domain.

Are you using Cloudflare (CDN, not just DNS) by any chance?

Ah, understood. No, we’re not currently using cloudfare.

To provide more background info, nginx was migrated over to to this box from a box that has since been deleted. I’ve also tried using -webroot but the webroot I see in the nginx config doesn’t exist on this box.

It appears the auto-renew did work. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.