Trouble installing lets encrypt through certbot / Digital Oean


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: soflotutors.com

I ran this command: certbot

It produced this output:
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for soflotutors.com
http-01 challenge for www.soflotutors.com
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.soflotutors.com (http-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up A for www.soflotutors.com

My web server is (include version): Apache

The operating system my web server runs on is (include version): Ubuntu

My hosting provider, if applicable, is: Digitial Ocean

I can login to a root shell on my machine (yes or no, or I don’t know): looks like it

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

Imgur

I’m brand new to wordpress/wed dev and am trying to make a small site for a tutoring business I run. Making the seems like a good way to gain some early experience and learn by doing. I’m having trouble using lets encrypt and now my url is returning 404 not found when I type in the IP address. Here is a screen grab of putty. Any help is appreciated.


#2

There seem to be some DNS issues.
The two names resolve to completely different set of IPs:

Name: www.soflotutors.com
Addresses: 104.239.213.7
198.105.244.11

Name: soflotutors.com
Address: 142.93.2.109


#3

From my location, www.soflotutors.com doesn’t exist.

You need to create a www DNS record in DigitalOcean’s control panel.


#6

My domain was up and running before I tried to install certbot and now I’m having a DNS problem


#7

Any idea what might be causing that? Here’s a screengrab of the domain


#8

The screengrab shows an A record for soflotutors.com, but no A record for www.soflotutors.com. You have to add one.


#9

Without the www IP, they probably resolve it to IPs for “parked site”.


#10

Thank you! You solved the problem. Any idea why/how my domain is showing 404 not found and how to fix it?


#11

The HTTP site is forwarding to HTTPS.
But the HTTPS site may not have the exact same DocumentRoot that the HTTP site had.
I’d check that first.
Or they have different DirectoryIndex(es)


#12

would I be better off fixing the document root or should i allow http traffic?

if so how would I go about doing that?


#13

If allowing HTTP is a simply change (like rem out a few lines), then I would do that first.

I would compare the two vhost configs.
They should be very similar.
Maybe you can post them here if you can’t see why it “fails”.


#14

im a beginner and found the solutions a bit over my head. opted to just restore my website from a backup and call it a day.


closed #15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.