Can't renew certificate. It was all working fine up untill now...
My domain is: rajivverma.tplinkdns.com
I ran this command:
root@Ubuntu-iMac-R:~# certbot --apache -d rajivverma.tplinkdns.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Renewing an existing certificate for rajivverma.tplinkdns.com
Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Domain: rajivverma.tplinkdns.com
Type: dns
Detail: DNS problem: NXDOMAIN looking up A for rajivverma.tplinkdns.com - check that a DNS record exists for this domain; DNS problem: SERVFAIL looking up AAAA for rajivverma.tplinkdns.com - the domain's nameservers may be malfunctioning
Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.
Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
root@Ubuntu-iMac-R:~#
It produced this output: Above
My web server is (include version): Apache
root@Ubuntu-iMac-R:~# apachectl -v
Server version: Apache/2.4.66 (Ubuntu)
Server built: 2026-07-06T15:33:20
root@Ubuntu-iMac-R:~#
The operating system my web server runs on is (include version): Ubuntu
root@Ubuntu-iMac-R:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 26.04.1 LTS
Release: 26.04
Codename: resolute
root@Ubuntu-iMac-R:~#
My hosting provider, if applicable, is:
I can login to a root shell on my machine (yes or no, or I don't know): yes
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
root@Ubuntu-iMac-R:~# certbot --version
certbot 4.0.0