Too many requests of a given type

My domain is:

I ran this command: certbot-auto --apache -d

It produced this output:

root@keepcontrol:~# certbot-auto --apache -d
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Cert is due for renewal, auto-renewing…
Renewing an existing certificate
Performing the following challenges:
tls-sni-01 challenge for
Waiting for verification…
Cleaning up challenges
An unexpected error occurred:
There were too many requests of a given type :: Error creating new cert :: too many certificates already issued for exact set of domains:
Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version): Apache/2.4.7 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 14.04.5 LTS

My hosting provider, if applicable, is: digitalocean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

It has been around 20 days and I still get the same error.

Here are some logs that might be useful in debugging the issue:

The result of sudo certbot certificate:

Renewal configuration file /etc/letsencrypt/renewal/ produced an unexpected error: expected /etc/letsencrypt/live/ to be a symlink. Skipping.
Revocation status for /etc/letsencrypt/live/ is unknown

Found the following certs:
Certificate Name:
Expiry Date: 2017-08-26 15:26:00+00:00 (VALID: 31 days)
Certificate Path: /etc/letsencrypt/live/
Private Key Path: /etc/letsencrypt/live/
Certificate Name:
Expiry Date: 2017-06-28 10:22:00+00:00 (INVALID: EXPIRED)
Certificate Path: /etc/letsencrypt/live/
Private Key Path: /etc/letsencrypt/live/
Certificate Name:
Expiry Date: 2017-10-06 11:10:00+00:00 (VALID: 72 days)
Certificate Path: /etc/letsencrypt/live/
Private Key Path: /etc/letsencrypt/live/

The following renewal configuration files were invalid:

I also commented out this command in crontab today as I feared it might of been responsible:

m h dom mon dow command
30 2 * * 1 /usr/local/sbin/certbot-auto renew >> /var/log/le-renew.log

Has anyone encountered a similar issue ?
Any help would be much appreciated.

Something on your machine has been issuing multiple certs for every day for several days now.

You should find out what’s gone rogue. Things to look for are automated tasks with either the --renew-by-default or --force-renewal options on the command line or in the ini file. This will force certbot to renew every time it runs instead of at the proper expiry period of 60 days.

1 Like

Thank you very much Jared.M.

I will keep an eye out for further certificate demands and locate where the automation is coming from.

It seems like the certificates are no longer being automatically issued.

I will await the 4 days missing before I can renew my certificate and give you feedback then.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.