There were too many requests of a given type

I tried to renew the certificate for several of my domains on the same server.
Several attempts failed due to “file not available” and “file already exists” errors and now
it rejects my renewal attempt because of “There were too many requests of a given type”.

At first I was trying some old version of certbot I installed manually that apparently self-upgraded (and warned abut using python 2) then I installed the version using apt-get (I am running Ubuntu 14.04 on this server).

My domain is: szabgab.com

https://crt.sh/?q=szabgab.com

I ran this command:
sudo certbot certonly --webroot -w /home/gabor/work/letsencrypt/ -d szabgab.com

  • a few other domains

It produced this output:

Processing /etc/letsencrypt/renewal/szabgab.com.conf


Attempting to parse the version 0.35.0 renewal configuration file found at /etc/letsencrypt/renewal/szabgab.com.conf with version 0.31.0 of Certbot. This might not work.
Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Attempting to renew cert (szabgab.com) from /etc/letsencrypt/renewal/szabgab.com.conf produced an unexpected error: urn:ietf:params:acme:error:rateLimited :: There were too many requests of a given type :: Error creating new order :: too many certificates already issued for exact set of domains: br.perlmaven.com,cn.perlmaven.com, Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/szabgab.com-0005/fullchain.pem (failure)
/etc/letsencrypt/live/szabgab.com/fullchain.pem (failure)

Web server nginx 1.4.6
OS Ubuntu 14.04

I am a bit lost on how long do I need to wait till I can retry and how to fix this.

ps. I had to remove most of the domain names because the forum “limits the number of links to 20 for new users.”

Hi @szabgab

first, you have hitted the limit ( https://check-your-website.server-daten.de/?q=szabgab.com#ct-logs ):

CertSpotter-Id Issuer not before not after Domain names LE-Duplicate next LE
958506440 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2019-06-09 13:26:07 2019-09-07 13:26:07 br.perlmaven.com, cn.perlmaven.com, codeandtalk.com, code-maven.com, cs.perlmaven.com, de.perlmaven.com, es.perlmaven.com, fr.perlmaven.com, he.perlmaven.com, hostlocal.com, id.perlmaven.com, it.perlmaven.com, ko.perlmaven.com, meta.code-maven.com, meta.perlmaven.com, perlmaven.com, pl.perlmaven.com, pydigger.com, ro.perlmaven.com, ru.code-maven.com, ru.perlmaven.com, sb.szabgab.com, szabgab.com, te.perlmaven.com, tr.perlmaven.com, tw.perlmaven.com - 26 entries duplicate nr. 5 next Letsencrypt certificate: 2019-06-16 13:21:11

5 identlical certificates with a lot of domain names.

So the certificate creation works.

But you don’t use it, instead there is an expired certificate:

CN=szabgab.com (9102)
	10.03.2019
	08.06.2019
1 days expired	br.perlmaven.com, cn.perlmaven.com, 
code-maven.com, codeandtalk.com, cs.perlmaven.com, 
de.perlmaven.com, es.perlmaven.com, fr.perlmaven.com, 
he.perlmaven.com, hostlocal.com, id.perlmaven.com, 
it.perlmaven.com, ko.perlmaven.com, meta.code-maven.com, 
meta.perlmaven.com, perlmaven.com, pl.perlmaven.com, 
pydigger.com, ro.perlmaven.com, ru.code-maven.com, 
ru.perlmaven.com, sb.szabgab.com, szabgab.com, 
te.perlmaven.com, tr.perlmaven.com, 
tw.perlmaven.com - 26 entries

Where are these certificates?

What says

certbot certificates

So it’s an installation problem, not a certificate creation problem.

Did you restart your server?

yeah, so the first time I got this error:

OSError: [Errno 17] File exists: ‘/etc/letsencrypt/archive/szabgab.com/privkey3.pem’
2019-06-09 14:21:14,210:ERROR:certbot.log:An unexpected error occurred:

Then when I removed that file I got this:

OSError: [Errno 2] No such file or directory: ‘/etc/letsencrypt/archive/szabgab.com/privkey3.pem’
2019-06-09 14:23:28,177:ERROR:certbot.log:An unexpected error occurred:

1 Like

Can you post “ls -alR /etc/letsencrypt/{archive,live,renewal}”?

1 Like

I checked and the symlinks in /etc/letsencrypt/live/szabgab.com were pointing to the version 2 cert files. Manually replaced the symlinks to point to version 3 of the cert files and restarted nginx.

curl -Ivv https://szabgab.com/

now tells me I have 3 more months.

@mnordhoff thanks for the idea to look again there.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.