Timeout during connect (likely firewall problem) Again :)

My domain is: xazzi.co.uk

I ran this command:

It produced this output:

My web server is (include version): IIS 10

The operating system my web server runs on is (include version): Server 2019

My hosting provider, if applicable, is: self hosting

I can login to a root shell on my machine (yes or no, or I don't know): N/A

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): N/A

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): win-acme.v2.1.14.996.x64

This file accessible over port 80 & 443 http://hyperion.xazzi.co.uk/.well-known/acme-challenge/test.txt

I get the error below

` Target generated using plugin IIS: hyperion.xazzi.co.uk

[hyperion.xazzi.co.uk] Authorizing...
[hyperion.xazzi.co.uk] Authorizing using http-01 validation (SelfHosting)
[hyperion.xazzi.co.uk] Authorization result: invalid
[hyperion.xazzi.co.uk] {
"type": "urn:ietf:params:acme:error:connection",
"detail": "During secondary validation: Fetching http://hyperion.xazzi.co.uk/.well-known/acme-challenge/GNeoc5LE6DPTvj-_oNF5Evv-cke6ZHI27ngYuCoNLLQ: Timeout during connect (likely firewall problem)",
"status": 400
}`

I have looked at the other threads with the same title but can't find anyone useing IIS

1 Like

Hi @HenrysCat

that's

the critical part. The primary Letsencrypt servers are able to connect your domain.

But the secondary servers are blocked.

Looks like you have a regional firewall or something else.

Find that and remove it.

2 Likes

So obvious yet I just did not see it :roll_eyes:

Thank you JuergenAuer :smiley:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.