There’s a problem with www prefixed domain security certificate


I recently deploy Let’s Encrypt SSL certificate using certbot on ubuntu server, it works perfectly on non www prefix domain => but display warning on www prefix website ==> and ask user to click the button to proceed.

Any ideas for troubleshooting to make it work here ==> perfectly.
This happen mostly on explorer browser
Thanks in advance


There is no certificate for the www form of your website, so your default virtual host’s certificate is being seen instead. Google Chrome has some magic to work around this that other browsers don’t, which is why you might only notice the error in Internet Explorer.

To fix the problem, you need to reissue your certificate to include the www form of your website. If you used certbot and the --apache authenticator/installer, the command to do so is:

sudo certbot --apache --cert-name --expand -d,

The cert-name is typically your domain name but you can run certbot certificates to be sure.

If you used some other option than --apache the first time you’ll need to use that here instead. If you’re not sure, please share the contents of your /etc/letsencrypt/renewal/ file so we can double-check.


Thanks @Patches, is working now after running sudo command above.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.