The requested apache plugin does not appear to be installed - Apache - python-certbot-apache IS installed

This seems to be a FAQ, but the usual remedies don’t work for me…

Server

Debian 9.1 (Stretch) 32 bit
Apache 2.4.25

Installed

sudo aptitude install certbot python-certbot-apache

What’s not working

I already have certs in place, generated before the upgrade to Debian 9.1.

Since the upgrade, I can no longer renew the certs, and when I run sudo certbot -vvv --apache, I get

Root logging level set at -10
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Requested authenticator apache and installer apache
No candidate plugin
Selected authenticator None and installer None
The requested apache plugin does not appear to be installed

Log:

2017-09-04 09:48:15,148:DEBUG:certbot.main:certbot version: 0.17.0
2017-09-04 09:48:15,148:DEBUG:certbot.main:Arguments: ['-vvv', '--apache']
2017-09-04 09:48:15,149:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#manual,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2017-09-04 09:48:15,164:DEBUG:certbot.log:Root logging level set at -10
2017-09-04 09:48:15,165:INFO:certbot.log:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2017-09-04 09:48:15,166:DEBUG:certbot.plugins.selection:Requested authenticator apache and installer apache
2017-09-04 09:48:15,166:DEBUG:certbot.plugins.selection:No candidate plugin
2017-09-04 09:48:15,166:DEBUG:certbot.plugins.selection:Selected authenticator None and installer None

Troubleshooting

I’ve tried uninstalling and reinstalling the certbot and python-certbot-apache packages, to no avail.

I do see the apache plugin installed in /usr/lib/python2.7/dist-packages/certbot_apache. The built-in plugins are in /usr/lib/python2.7/dist-packages/certbot/plugins/. Could this be the issue?

It looks like you may have added certbot twice.
Package “python-certbot-apache” should already include certbot.

Package managers will resolve such things, and aptitude certainly does. Certbot is installed only once.

Hi @paour,

The log shows that you are using certbot 0.17.0 but Debian Stretch packages certbot version 0.10.2. Did you install it from other repository?.

Cheers,
sahsanu

1 Like

This was indeed the issue, thank you for pointing me in the right direction!

I had both the Debian version and the pip package installed. Removing the pip version caused me to experience this error, so I bit the bullet and (contrary to the instructions) removed the Debian package for certbot and installed only the pip version:

sudo pip install certbot certbot-apache

That worked fine.

2 Likes

I may have misunderstood your post to mean that sudo aptitude install certbot python-certbot-apache would cause certbot to be installed twice.

You were correct in indicating certbot was installed twice: once by apt/aptitude and once by other means (probably as I tried various ways to resolve missing dependencies).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.