The request message was malformed :: Method not allowed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:11 domains

I ran this command: certbot renew --dry-run
certbot certonly --webroot -w /bla/bla/webroot -d --dry-run

It produced this output:Attempting to renew cert from/etc/letsencrypt/renewal/ produced an unexpected error: urn:ietf:params:acme:error:malformed :: The request message was malformed :: Method not allowed. Skipping.

My web server is (include version): nginx and varnish

The operating system my web server runs on is (include version):Centos 7

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):Certbot version: certbot 0.36.0

1 Like

The latest version of Certbot available for CentOS 7 is 0.39.0. Upgrading using these instructions:

Even so, 0.36.0 should not have this problem.

Could you also check this:

rpm -q python2-acme
1 Like

Thank you for your prompt reply.

rpm -q python2-acme

The instructions you gave me are for installation, not for upgrade of certbot.

1 Like

There's no difference, since you installed Certbot originally from the same source. yum install will perform an upgrade if the package already exists.

There is your problem. The specific issue you are suffering from was fixed in 0.31.0-2.

You could potentially just upgrade that package with:

yum -y install python2-acme

but I would be wary about other outdated dependencies. Better to upgrade everything.


Thank you! I will try all these and update this issue.

1 Like


yum install certbot python2-certbot-nginx
yum install python2-acme

solved the problem.

Thanks again!!! :wink:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.