The renew command output said it's not needed to renew, but when I visit, the browser told me "the certificate expired..."

Please fill out the fields below so we can help you better.

My domain is:

I ran this command:

/usr/local/sbin/certbot-auto renew

It produced this output:

Requesting root privileges to run certbot...
  /home/ubuntu/.local/share/letsencrypt/bin/letsencrypt renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /etc/letsencrypt/renewal/
Cert not yet due for renewal

The following certs are not due for renewal yet:
  /etc/letsencrypt/live/ (skipped)
No renewals were attempted.

My web server is (include version):

nginx version: nginx/1.4.6 (Ubuntu)

The operating system my web server runs on is (include version):

No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.4 LTS
Release:	14.04
Codename:	trusty

My hosting provider, if applicable, is: aws

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The renew command output said it’s not needed to renew, but when I visit, the browser told me “the certificate expired…”

any help ?


Hello @imwhatiam,

You already have a cert for valid till 1 Oct

Did you reload/restart your web server?.


It seems you didn’t use the nginx plugin while initially creating this certificate, as this would automatically reload nginx after obtaining a certificate. What appears to have happened was that you renewed your certificate, but nothing reloaded nginx to apply this new cert. Try running an nginx reload. If that works, next time you can add the reload command with a --post-hook flag to reload nginx after the renewal completes.

Yes, reloading nignx solved the problem.

Many thanks.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.