System32 gives me an error

Guys, I am an absolute beginner so this question is probably not too clever but it has not been answered yet.

I am trying to follow the certbot instructions, I have installed certbot and entered the shell.

If I now copy paste the line from the instructions
C:\WINDOWS\system32> certbot certonly --standalone
it tells me that system32 could not be found. What do i do?

1 Like

I'm actually not sure why the certbot instructions for Windows have the system32 path mentioned, as it isn't actually used anywhere.

Also, you didn't type C:\WINDOWS\system32> certbot certonly --standalone literally in total, right? Because the C:\WINDOWS\system32> part of that sentence just marks the current path of your CMD shell and shouldn't actually be typed in the shell.. Only the part behind the > should be typed (without the leading space, so it starts with certbot followed by the rest of the command).

Also, it shouldn't really matter which path your shell is in, it doesn't have to be C:\WINDOWS\system32 as far as I know.

3 Likes

damn thats exactly what i did :slight_smile: thanks a lot, as you see Im really new to this

2 Likes

Not a problem. I guess the documentation does state "The user needs to be familiar with the command-line interface (CLI)" which would probably also mean the ability to read the usual formatting of command line instructions, such as the one discussed here.

If you need any further help, don't hesitate to ask! (After you've at least tried to get it working yourself for a bit of course :wink:)

3 Likes

OK i tried for two hours but i really dont know how to do it... Maybe I should just pay but I would love one more try :slight_smile:

So I tried everything with cmd and it gives says I should check if i got the correct IP, but what the hell is the correct IP? I got one, but how do I know if its correct?

I really appreciate your help osiris :slight_smile:

1 Like

The #Help section usually has a questionnaire with a few questions which are actually quite helpful, mandatory even perhaps:


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):


If you could fill it out to the best you can, we can help you the best. Please be as complete as possible. For example, we'd like to see the entire command you've entered. And also the entire output, preferably with the correct formatting for this forum by putting three backticks (```) above and below the output.

4 Likes

OK ill try my best:

my webserver is: server365 with operating system LiteSpeed, SQL version 10.2
My hosting provider is hostinger
Certbot version certbot 1.10.1
i manage my site via wordpress
i dont know how to access a root shell

I ran this command: '''Please enter in your domain name(s) (comma and/or space separated) (Enter 'c'
to cancel): axtwerfen.de

this was the result: '''Requesting a certificate for axtwerfen.de
Performing the following challenges:
http-01 challenge for axtwerfen.de
Waiting for verification...
e[31mChallenge failed for domain axtwerfen.dee[0m
http-01 challenge for axtwerfen.de
Cleaning up challenges
e[31mSome challenges have failed.e[0m
e[1m
IMPORTANT NOTES:
e[0m - The following errors were reported by the server:

Domain: axtwerfen.de
Type: unauthorized
Detail: Invalid response from
http://axtwerfen.de/.well-known/acme-challenge/jaNjmn8_knzdRVt6f-gp9W9PnQ7XEwaWouuBZNXqPpk
[212.204.99.205]: "<?xml version="1.0"
encoding="ISO-8859-1"?>\n<!DOCTYPE html PUBLIC "-//W3C//DTD
XHTML 1.0 Strict//EN"\n "http://www.w3.org/TR/xht"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

Probably some things here are wrong, but i tried my best :confused: thanks a lot man

1 Like

So I'm assuming you're running certbot on a different computer than the server on which your site is hosted, correct?

Because certbot is usually ran on the computer/server which is also running the website. This is because of the way Let's Encrypt validates the domain name. Please see this documentation page for more info:

It also seems Hostinger provides a Let's Encrypt certificate for as far as I can see all their webhosting services? You probably don't even need to run certbot at all. However, I can't find the "Server365" mentioned on their site. So I'm not sure what kind of webhosting plan you have. Do you have access to the cPanel control panel? If so, you might want to have a look at this Support Page from Hostinger:

There are also some other Hostinger pages out there with a whole different story with a lot more difficult installation method from ZeroSSL (which isn't Let's Encrypt): https://support.hostinger.com/en/articles/1583255-do-you-support-let-s-encrypt-ssl-certificates and https://www.hostinger.com/tutorials/ssl/how-to-install-free-ssl-from-lets-encypt-on-shared-hosting
I would not recommend those latter two, as it isn't automated, while the guide above (cPanel) is fully automated.
They also would like you to purchase a certificate from them "if it's all to much of a hassle".. Sure.. Of course they would like that! :frowning: Luckily, if you have cPanel and the above automated guide works, that won't be necessary at all!

2 Likes

thank god for your help, i was about to just buy the SSL to save the hassle XD
I have something called hpanel


And i did try zero ssl, but i failed with all 3 of the authentification methods. I dont have an email plan, I dont know how to set dns servers which point to another and i dont know how to upload a file to a specific url :confused:
Do you know which one is the easiest and how to? I literally spent two days on this instead of actually producing content, without your help i bet it would be weeks...

1 Like

It does mention Let's Encrypt at the top of your screenshot? The site https://3d-printed-house.com/ has a Let's Encrypt certificate enabled perfectly. Where is the option for axtwerfen.de? Or was the certificate for 3d-printed-house.com added manually too?

2 Likes

yeah, the first site you get one for free from hostinger...

afterwards you either add manually or pay them to do it

1 Like

Seriously..? Oh my.. That's just criminal.

In any case, adding it manually isn't that hard. Unfortunately, it would be someting which has to be done every 90 days (preferably earlier, about after 60 days to be on the safe side if something goes wrong!). That's why Let's Encrypt hammers so hard on automation. ZeroSSL certs are also short-lived, unless you'll willing to pay them too.

Anyway, you already have certbot installed on your computer, so why not get a free Let's Encrypt certificate, right?

The only difference this time is: earlier you ran certbot with certbot certonly --standalone, now you're going to use certbot certonly --manual. To make it easier on yourself, you can already enter some information for certbot on the command line too:

certbot certonly --manual -d axtwerfen.de -d www.axtwerfen.de

It will ask you something like this:

Create a file containing just this data:

lzPYqafSThRbq7Ld3UKv_g5TOHFhjdCq-dSm4naKahg.1ycc0UUde6VR4w9LvReDlzlMW7fwMtHBU4DalYcq-fs

And make it available on your web server at this URL:

http://axtwerfen.de/.well-known/acme-challenge/lzPYqafSThRbq7Ld3UKv_g5TOHFhjdCq-dSm4naKahg

It won't be those exact values, but different, but you just got to do what certbot is asking of you: make a extensionless file with that content at the top and rename it to the value after /acme-challenge/ in the URL at the bottom.

Use whatever method you're regularly using to upload files to your webhosting. For example, you might use your hPanel like the guide for ZeroSSL is doing or you might be using FTP. It doesn't matter, as long as you put the file in the right directory (/.well-known/acme-challenge/) of your site.

When you've uploaded that file, you should try to open that URL and check if you can access it. It should give that weird value you've put into it in your browser.

If you can open the URL in your browser, you can press ENTER to continue as asked by certbot. DON'T press enter before the file is accessible in your browser!

After you've pressed enter, you'll need to do the same for your www subdomain.

When both challenges have succesfully completed, certbot should have saved your brand new Let's Encrypt certificate and private key in C:\certbot\live\axtwerfen.de\

There you can upload the contents of cert.pem as "Certificate (CRT)", privkey.pem as "Private key (KEY)" and chain.pem as "Certificate authority bundel (CABUNDLE)" in your hPanel.

By the way, you might want to check your websites configuration in general. If I go to http://axtwerfen.de (without the www) I just get the text "It works!" as a response, but when I surf to http://www.axtwerfen.de I can see your actual site? This might also prove a problem for getting a certificate for the axtwerfen.de hostname without the www, if Let's Encrypt can't reach the special file you've created earlier.

1 Like

damn all of this is hard.... i am trying to create the file right now but usually I just upload a file I already got... when i try to enter the location as file name it gives me an error...

What's the issue? How do i create a file... and most importantly, how did i make it 3 years through online marketing without learning the basics of the basics onwebsites :confused:

Just make it on your own computer first and then upload it. Notepad.exe should also be able to save files without an extension (doublecheck it didn't save it as a .txt).

Also, I'm pretty sure you have to make the directory .well-known first, then make the subdirectory acme-challenge in that directory and then upload the file.

1 Like

ooohhh man i just created three different files.... Do you have any idea how to create a subdirectory? I just went through all of youtube, they dont know it or speak hindi.

Is this the right help section? it didnt really work https://support.hostinger.com/en/articles/1583523-how-to-setup-directory-listing

1 Like

No, that's something different.

I don't have any experience with that 'hPanel', sorry. But there is a Hostinger help document about the hPanel File Manager:

It also contains a "New folder" button. Use that one.

1 Like

One thing I noticed is instead of having the challenge in http://axtwerfen.de/.well-known/acme-challenge/, your screenshot shows you have /domains/axtremsport.de/public_html/.well-known/acme-challenge/(test filename). Notice the public_html in there? Certbot isn't expecting that in the path.

1 Like

thats kind of a thing with hostinger, you can only upload public content in public.html, it gets cut later :slight_smile: but thanks for the reply, i finally got my website certified and learned a lot for the future

1 Like

Osiris thank you so much for walking me through this. I finally got my website secured and the ssl installed :slight_smile: i appreciate your help a lot, and I think I learned a lot!

Very much appreciate your patience, youre a great guy

2 Likes

Great to hear it! :clap:

I'm not at all familiar with hostinger - just seemed that sub-folder looked out-of-place in the usual path. We both learned something. :smiley:

2 Likes