Synology Certificate couldn't be generated

So i have a synology nas and a custom domain, and used a Let's Encrypt Cert, which worked, but it didn't work for the newly added Subdomain, so i wanted to recreate a new cert, to add the subdomains in, then i got the error: that my domain could not resolve to a public ip, so i checkt the DNS settings at my domainprovider and changed the subdomain form cname to a records. the same error came e few times i attemted to change various things with the DNS until i now get the error: Maximal Certificat request reached for Domain. but i still dont have a Cert on my NAS for my Domain.

My Domain:
Synology version: DSM 7.2.1 - 69057 U3

Could someone please help me?

If using HTTP validation, check that all of the names you want actually resolve to your desired server (and therefore the ACME client that's helping you respond to the http challenges).

These are the Let's Encrypt Rate Limits:

Here are some of your recently issued certs:

They've probably given you 5 certs already for the same set of names so you have to wait a week to do it again, or use a different CA. If you add or remove a name from your cert then it won't be considered a duplicate anymore.

I'd suggest there is some other problem though if your system is successfully ordering certs but not applying them, and you'd at least need detailed logs from synology to investigate that.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.