Synology NAS can't get cert due to invalid domain name

It's been years I've using LE, but I got alert yesterday that the cert for my domain name is outdated.
That's when I realized the renewal is not working since april til today.
I tried to request a new cert, but got error message said "The domain name is invalid, make sure the domain name can resolve to public IP."
But I can still use both domain name and IP to access my website.
Please help since I have no clue why this happened.
Thanks.

My domain is: naviart.idv.tw

I ran this command:

It produced this output:

My web server is (include version): Synology NAS with Nginx

The operating system my web server runs on is (include version): DSM 7.1-42661 Update 3

My hosting provider, if applicable, is: Synology NAS

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Synology DSM

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): N/A

Welcome to the community @guiTart

I don't see any problem with your domain name or DNS records. I sent a test request like an acme challenge and got the expected response (a 404). The Let's Debug test site also says it should work.

My best guess is something has gone wrong with DNS lookups on your NAS. You should ask about this on the Synology forums.

I don't know the DSM system but can you run commands like this one?

nslookup naviart.idv.tw

Does it work?

4 Likes

Hi, Mike.
Thanks for the warm welcome and decent comments.
The command nslookup returns with correct IP.
I will check if something wrong with my NAS unit.
Thanks again.
Cheers!

4 Likes

Turns out it's because I deleted an unused sub-domain name in my domain record table months ago which made LE unable to resolve the IP of it.
I succesfully got new certification by removing this sub-domain from appling form.
Thanks for Mike's helping.
Cheers!

2 Likes