SurgeMail Automatic cert failing

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
tellmail ssl_update

It produced this output:
SurgeMail Version 7.4e-1, Built Dec 23 2019 23:02:47, Platform Linux_64
Key OK,, Expires in 28 days active=0 updates=26/Jul/2022
Update starting
Update domain relay
Existing cert check: relay Self signed certificate /CN=relay
Got newAccount =
Account status: Account found/created
acme_neworder failed relay response: {
"type": "urn:ietf:params:acme:error:rejectedIdentifier",
"detail": "Error creating new order :: Cannot issue for "relay": Domain name needs at least one dot",
"status": 400
Update finished, 0 good, 1 bad

My web server is (include version):
SurgeMail Ver 7.4e-1

The operating system my web server runs on is (include version):
Ubuntu 16.04.12

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
Not using certbot

I'm trying to upload my "surgemail.ini" but I can't find an attachment or upload button in this community website.

I have no idea how SurgeMails implementation of Let's Encrypt works, but currently it thinks its hostname is "relay" and it's also trying to get a Let's Encrypt certificate for the hostname "relay", which is obviously impossible.

Please check your SurgeMail configuration for setting its hostname and correct it to the appropriate hostname or hostnames.

1 Like

That makes sense. I'll give it & try.

1 Like

That was the problem, & a valid cert is issued & working. Thanks for the pointer. I don't see a "solved" or "fixed" button on this site, but thanks!


It's possible to mark posts as "Solution". I've been so cheeky to mark my own post as the Solution in this case :wink:


Feel free to mark it as solved. I'd send you a couple gold stars too, but I can't fit them in this small cable.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.