Supplied wrong domain names (?) - vhost setup apache

At the moment you are providing http not https on port 443. What did you change ? Was that just moving the IfModule statements ?

If so, it sounds as if you don’t have the module installed - which would explain why none of that file was being used when you had the IfModule statement around it.

To test - if you just remove the IfModule statement ( both lines), what does that give ? (alternatively you may need to install the module - yum install mod_ssl )

Bingo!!! :grinning:

I already did the installation thing, mod_ssl is there. It looks as if the test in the conf fails. Weird?

odd - not sure why the test for the module fails. Glad you have things working though :slight_smile:

So, the self signed VPS cert was not the real problem, it did not interfere with the letsencrypt cert. The real problem was the virtual host setup: the IfModule mod_ssl.c statement did not pass. Weird.

Thank you so much for your patience and time. And you pinpointed the problem very accurately. :slight_smile: Cool!!

Correct. You’re Welcome :slight_smile:

To start with you had the whole of the domain config wrapped in the “IfModule mod_ssl.c”, so it was ignored.

When you reduced the “IfModule mod_ssl.c” to just the “SSLEngine on” and cert details, that got ignored - and hence it was only providing http on port 443.

One you removed the “IfModule mod_ssl.c” test altogether, it was all read, and hence worked.

I’ve no idea why the “IfModule mod_ssl.c” test failed though - lets see if anyone else knows why.

Correct analysis. But the mishap was caused by the "IfModule mod_ssl.c" test in the vhost conf file. The test failed, hence the configuration was not executed. Any idea why the test fails??