Suddenly can no longer auto-renew

My domain is:
coreykepple.com

I ran this command:
certbot renew

It produced this output:

My web server is (include version):
nginx/1.10.3 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 16.04.2 LTS (GNU/Linux 4.4.0-83-generic x86_64)

My hosting provider, if applicable, is:
digitalocean

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

Just a side note, I was able to create a index.html file @ /usr/share/nginx/html/.well-known/acme-challenge/test and hit it from the browser. My SSL cert is still valid until the 30th, but I can no longer renew. I’m really not sure what happened to the acme-challenge that must have been there before this stopped working.

You’re right, it does seem to work… :confused:

What does the .conf mentioned at the top of the screenshot contain? What does the Nginx configuration contain? Are they configured to put files in the same place? What does Nginx’s error.log say? Or /var/log/letsencrypt/letsencrypt.log?

Ok going to answer in order (multiple posts since I’m only allowed one image per):

Here is the /etc/letsencrypt/renewal/coreykepple.com.conf:

Here is the nginx config (gonna be 3 photo’s because it uses 2 snippits)

(ssl-param)

(certs)

Nginx Error:

The letsencrypt log has a ton of output so I’m not sure the best way to share it, also I really don’t know what I’m looking for in there, but here is the last output:

2017-09-23 20:59:21,096:DEBUG:certbot.log:Exiting abnormally:
Traceback (most recent call last):
File “/usr/bin/certbot”, line 11, in
load_entry_point(‘certbot==0.14.2’, ‘console_scripts’, ‘certbot’)()
File “/usr/lib/python2.7/dist-packages/certbot/main.py”, line 742, in main
return config.func(config, plugins)
File “/usr/lib/python2.7/dist-packages/certbot/main.py”, line 692, in renew
renewal.handle_renewal_request(config)
File “/usr/lib/python2.7/dist-packages/certbot/renewal.py”, line 435, in handle_renewal_request
len(renew_failures), len(parse_failures)))
Error: 1 renew failure(s), 0 parse failure(s)

(sorry for the post spam)

Certbot is configured to put files in /var/www/html/. Nginx is configured to serve files from /usr/share/nginx/html/. One of them needs to be changed to match the other.

Personally, i’d avoid /usr/share/nginx/html/ since it’s part of the OS Nginx package and not really intended to serve other files.

1 Like

Thanks for the response, I’ll give that a try (updating the Nginx config). Do you happen to have any insight into how I might do that…(gonna start researching on my own). Or even better, how this change might have happened without me knowing? As I said I had auto-renew working as expected and this failure kind of began out of the blue. Thinking maybe some auto-update caused a change?

FYI, I added
root /var/www/html;

to the server block of the sites-available/default file, and it seemed to resolve the issue. No idea how i lost that but I really appreciate the help here, this can be marked solved!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.