Strange error on DNS challenge

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
optgeo.top

I ran this command:
request from my own code

It produced this output:
'error': {'type': 'urn:ietf:params:acme:error:unauthorized', 'detail': 'Incorrect TXT record "Mi5gZCasHPZUrQF5mlDYY-fA86Tm0DiRuB84_GMNsus" found at _acme-challenge.optgeo.top', 'status': 403}, 'token': 'Mi5gZCasHPZUrQF5mlDYY-fA86Tm0DiRuB84_GMNsus'}

In addtion, I run my code in the staging environment.

I moved your post to the Client Dev section.

Is this the first time you have tried to use an ACME Server?

Because each challenge request has a new TXT value which must be encoded properly. This is another similar thread about that

4 Likes

It's so grateful for your rapid respond and the problem has been solved! It's actually my first try on an ACME Server

1 Like

For future readers: what seemed to be the issue and what fixed it?

1 Like