SSL not allowing embed codes

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: hosted on ipage. My embed codes work perfectly fine with no problems whatsoever WITHOUT the SSL enabled.

I ran this command: Enabled your SSL allowed on my ipage site because we NEED a secure site.

It produced this output: When your SSL is enabled, it does not allow my embed codes to work. One code is from my Ecwid Store which worked find before SSL enabled. The other is from my video channel on Wistia, which also worked fine before the SSL was enabled.

My web server is (include version): ipage WebBuilder

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: ipage

I’m using a control panel for a web builder with ipage.

AGAIN, everything works perfect when the SSL is disabled. When I enable your SSL, my embed video and my embed code for my Ecwid store stops working and will not publish to the website. It just shows gray boxes and doesn’t have the actual items appear.

Is there a work around? A way to unblock these safe locations and allow them to show on my ipage website?

1 Like

Hi @tolsen

checking your site there are some small errors -

But nothing with your problem. Critical: JavaScript / CSS via http, but there is no such active mixed content.

Do you have samples? I don't see a video element.

1 Like

Are you bringing in video elements from VIMEO? I see un-encrypted links that reference, and 21 others… those should be changed to “HTTPS://”
Might Help


Ah - thanks - there is JavaScript with some http links -> that can’t work if you use https.

And “check your website” doesn’t analyze JavaScript.

1 Like

Apparently ssllabs doesn’t either. :woozy_face: But theres some cypher issues capping the “grade”


That's expected. Ssllabs doesn't check content, redirects etc.

Yep, one is really bad: RC4 should be removed. But it may be impossible because it's an iPage-configuration.


So… iPage (live chat) says they allow clients to access vhost config files via “VPS host”… So the cyphers may be tweak-able after resolving non https links! They’re hosting with:

  • CentOS 6.4
  • cPanel

Although, root access is optional… dont know if @tolsen would need root (I dont use/know cPanel)

Might help.

Thank you for your efforts. I’m not a code writer, so my responses may or may not be what you are seeking. However, I’m fairly good at working through issues and following instructions, so please don’t hesitate to share any possible solutions / codes I may need to add or remove. THANK YOU!!

This is the video embed code from Not using vimeo or youtube due to the required ad pages and unrelated videos at the end…doesn’t look very professional with that spam junk on there. I did use Youtube in the past until they started that. And, I am more than happy to continue to use YouTube if you can tell me how to get rid of the spam ads and unrelated videos at the end of our video.

Otherwise, following is the embed code from Wistia.


preview on editing page

But, this is the link to the published site with the SSL enabled, which is not showing the video.

Thanks everyone for the attempts to help. It has become very obvious from a week’s worth of discussions and chats that it is a problem within the iPage system, especially since they admitted that multiple sites have this same issue. Unfortunately, the technical support folks still haven’t figured it out. So I went back to the http unsecure, BUT, our online store is supported through an encrypted ecommerce site. Therefore, we have to move forward and let them figure it out without our site being another casualty of long delays.

Again, thanks to all of you for trying!



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.