SSL Installation issues

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://www.ajxstores.com

I ran this command:
certbot --nginx --redirect -d www.ajxstores.com -d ajxstores.com -m [redacted]@gmail.com --agree-tos --no-eff-email

It produced this output: Successfully ssl installation. But my site still shows unsecure

My web server is (include version): Ubuntu 20.04 x64

The operating system my web server runs on is (include version): WordPress on Ubuntu 20.04 x64

My hosting provider, if applicable, is: namecheap

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot) certbot-auto --version

my hosting provider is Vultr.

Your Wordpress configuration makes Wordpress redirect to https://70.34.223.236/ which is not what it's supposed to do.

Most often this is due to incorrect settings for "WordPress Address (URL)" and "Site Address (URL)" in the "General Settings" Wordpress menu.

Sometimes Wordpress has some redirect plugin installed, but check the above first.

5 Likes

It is a "permalinks" thing.
Settings >> Permalinks
Use the Domain Name - NOT the IP
Hope this helps.

4 Likes

Thank you very much. Finally, it was so simple.

Best Regards
Support Team
Ajx Stores

4 Likes

Thanks a lot, my friend.

Best Regards
Support Team
Ajx Stores

1 Like