SSL install troubles - Failed authorization procedure - To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address


#1

Hi Folks, I’m struggling with trying to install a security cert so I can migrate to HTTPS for my forum.
Google says the error I’m getting below is a generic one.
And I am unable to access the file location (page not found error).
A webpage pointed to http:// or http://www both send you to my website.
But an NSlookup failed on those two, if that matters.
NSlookup for www and labusas.org both worked fine.

Error output is below:

[root@server_name]# certbot certonly --webroot -w /var/www/labusas -d www.labusas.org
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for www.labusas.org
Using the webroot path /var/www/labusas for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.labusas.org (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://www.labusas.org/.well-known/acme-challenge/Ld0fLntnscNW-1bXdW1GdNpA98VNi8Sxc-HlVqZRK2w: “\n<html id=“XF” lang=“en-US” dir=“LTR”\n\tdata-app=“public”\n\tdata-template=“error”\n\tdata-container-key=”"\n\tdata-cont"

IMPORTANT NOTES:

My domain is:
labusas.org

I ran this command:
certbot certonly --webroot -w /var/www/labusas -d www.labusas.org

It produced this output:
(see above)strong text

My web server is (include version):
LiteSpeed Web Server 5.3

The operating system my web server runs on is (include version):
CentOS 6

My hosting provider, if applicable, is:
Linode

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
LiteSpeed Web Server 5.3


#2

Let’s check if that is the correct webroot:
Place a test text file as follows:
sudo mkdir /var/www/labusas/.well-known
sudo mkdir /var/www/labusas/.well-known/acme-challenge
echo "test file is OK" >/var/www/labusas/.well-known/acme-challenge/1234`

Then we check with:
http://www.labusas.org/.well-known/acme-challenge/1234
If that fails, then you are not using the correct webroot path.


#3

Hi rg305, thanks for helping out!
The test appears to have failed.

[root@servername~]# mkdir /var/www/labusas/.well-known
[root@servername~]# mkdir /var/www/labusas/.well-known/acme-challenge
[root@servername~]# echo “test file is OK” >/var/www/labusas/.well-known/acme-challenge/1234`

^C
[root@servername~]# echo “test file is OK” >/var/www/labusas/.well-known/acme-challenge/1234

I wasn’t sure if the ’ should be at the end of the command, so I ran and tested it both ways.
Both of the tests gave me a standard labusas page-failed message.

I’m not sure how to resolve the correct webroot path issue.
I’m going to start researching right now though.


#4

OMG, it was so simple.
webroot = the root director where your website files are stored.

In my case, it is:
/usr/local/lsws/sites/website_name/public_html

I just got a “Contratulations” so I think I’m moving forward. Thanks for pointing me in the right direction!
I had been using what litespeed said to use for webroot and did not connect the dots.