SSL for WordPress using LightSail

Hello everyone,

I’m new using Amazon LightSail. I’m following this link: https://lightsail.aws.amazon.com/ls/docs/en_us/articles/amazon-lightsail-using-lets-encrypt-certificates-with-wordpress

I’m trying to configure the SSL certificate for WordPress, I’m on the Step 5 on the Guide. When i use MX Toolbox to verify the DNS Record until now it showing “DNS not found”. It’s been a day since I added it to the panel, but it hasn’t propagated yet.

what’s the problem? I’ve tried to follow the guide several times, I don’t understand what I’m doing wrong.

Thanks for help.

Note: At this moment, the site is hosted on another server and the domain is registered with another company. We just want to migrate the site to AWS. We already did, we are just configuring SSL.

Check my image, please:

My domain is:
www.vinicom.pt

I ran this command:
sudo certbot -d $DOMAIN -d $WILDCARD --manual --preferred-challenges dns certonly

It produced this output:
Display 2 DNS Zone TXT Records. I added on the Network panel .

My web server is (include version):
Linux Server

The operating system my web server runs on is (include version):
I think is Linux OS.

My hosting provider, if applicable, is:
Amazon LightSail

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
LightSail’s Control Panel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
I have the latest version. I ran the commands to update the system.

Don’t use MX toolbox, it only checks MX records. You need to check A and TXT records.

also: you are not using amazon’s nameservers, so whatever you put there is not considered.

% dig vinicom.pt ns

; <<>> DiG 9.16.1-Ubuntu <<>> vinicom.pt ns
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46363
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;vinicom.pt.			IN	NS

;; ANSWER SECTION:
vinicom.pt.		3599	IN	NS	ns2.ptempresas.pt.
vinicom.pt.		3599	IN	NS	ns1.ptempresas.pt.
vinicom.pt.		3599	IN	NS	ns10.ptempresas.pt.

;; Query time: 88 msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: mar apr 14 12:16:38 CEST 2020
;; MSG SIZE  rcvd: 105

Hello 9peppe,

Our domain is registered on the ptempresas.pt.
Do i need to add the amazon nameservers at this company?

Thanks for reply.

Hi @SergioCosta86

there is a check of your domain, ~~30 minutes old - https://check-your-website.server-daten.de/?q=vinicom.pt

These

vinicom.pt
	•  ns1.ptempresas.pt
	62.28.40.139
Lisbon/Portugal (PT) - PT Prime	•

	•  ns10.ptempresas.pt
	185.17.231.126
Lisbon/Portugal (PT) - PT Prime	•

	•  ns2.ptempresas.pt
	62.28.40.141
Lisbon/Portugal (PT) - PT Prime	•

are your name servers, nothing else.

If you use dns validation + manual, your TXT entry must be visible. But there

is nothing visible. Should look like

You should decide that for yourself. You can either add the records on your current nameservers, or switch nameservers at your registrar.

Ok. I will do it. I will go to ask the domain company to add my nameservers. After that, the SSL can work, right?

Apparently the domain server does not exist.
In this case, do i need to add my amazon’s nameservers where is domain registered, right?

This is my doubt.

Thanks for help.

If you use dns validation, you don’t need a working website.

That’s not required. Change your ns1.ptempresas.pt directly, if you use --manual.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.