SSL certificate unable to create

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: tried to create ssl cert thru NGINX

It produced this output: INTERNAL ERROR

My web server is (include version):

The operating system my web server runs on is (include version): raspbin lite

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): NA

What does this mean exactly? Could you please elaborate?

1 Like

Hi @yankieddl, and welcome to the LE community forum :slight_smile:

Are you sure about that name?
I can't resolve it to any IP address.
I do see an IP for:

Thanks Osiris for prompt reply.

Have installed nginx, mysql and duckdns thru portainer. Wanted to run nextcloud on https for which i need to create ssl cert while adding duchdns host on nginx. But everytime i add the details and save it delivers internal error.

1 Like

OK, so you're probably using some build in feature of Portainer ("Portainer is a universal container-as-a-service platform that works with Docker, Swarm and Kubernetes.", I've never heard of it, nor do I have any experience with it..) to get a certificate? Because as far as I know, nginx does not have such a feature.

Could you perhaps elaborate more about the process of how you're trying to get a certificate?

1 Like

I want to run nextcloud on https for which i need to create ssl cert. for duckdns subdomain.

Now nextcloud is running fine on http. When i try to create ssl cert for the duckdns host using nginx ssl tab, it delivers internal error.

Sorry if i havent explained you well as i too am noob.


I'm trying to figure out HOW you're trying to do this.. Could you walk us through the process? Which buttons did you click? Which application are you using to do that?

1 Like

Pls see attached pic

Hope this helps.

1 Like

I give up. Even with that screenshot, I don't know what application I'm looking at. Maybe someone else can help you further. @rg305 also asked a question earlier, perhaps you could answer his question and maybe he can help you further. Good luck in your endeavours.

1 Like

I m able to access nextcloud using http.

To access nextcloud using https i need to create ssl cert so i am going thru nginx proxy----->> add proxy host----->>i use hhponpi4. Then i go to ssl tab on same window to create ssl cert for the above host and upon saving it generated internal error as seen in pic sent earlier.

Hope this helps

@yankieddl I think the other responders understand what you are saying. But, no one is familiar with that app that displays the screen with your 'ssl' tab. Because no one knows what that app is, it is impossible to assist. The people here have seen a lot - just not that one. I saw many examples in google of using the more common Certbot client app on Raspberry Pi - but I also could not find anything like the app you describe.

Someone wrote that app. If you can discover who that is perhaps you can contact them for help. The 'Internal Error' message is not very helpful and may not have anything to do with Lets Encrypt. If the author can provide more detailed explanation of what is failing perhaps someone here can further assist.


Maybe you can start by showing the nginx configuration, with the output of:
sudo nginx -T

Hi, you need to go to the GitHub page for the software you are using (not Let's Encrypt, they didn't write this software) and ask for help there. They can point you to where to look for log files etc.

As mentioned on the other thread (Nextcloud letsencrypt cert unable to create - #5 by Osiris) you need to start by getting TCP port 80 and port 443 to forward to your server, that makes your web server accessible from the internet and in turn let's HTTP validation of your domain more likely to work.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.